summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/colorize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/colorize')
-rw-r--r--dev-ruby/colorize/Manifest2
-rw-r--r--dev-ruby/colorize/colorize-0.7.5.ebuild24
-rw-r--r--dev-ruby/colorize/colorize-0.7.7.ebuild30
-rw-r--r--dev-ruby/colorize/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/colorize/Manifest b/dev-ruby/colorize/Manifest
new file mode 100644
index 000000000000..2d436d15995d
--- /dev/null
+++ b/dev-ruby/colorize/Manifest
@@ -0,0 +1,2 @@
+DIST colorize-0.7.5.gem 14848 SHA256 c84253400dc0baf5a11c2b04b0b85e1a122f923771602dec45cee61d1a72c564 SHA512 a4d286d1b7b4e7c028200318718eaa02c01705ee4ae8f504737bfdd4ed5f70aa77b20cc94fd938a4e0b121fea478b5b757584d8b05202adb33bd2b9c9e294b36 WHIRLPOOL 2b0ad1a335071d4f33caef688bbfe9a2e6d58689ee5c7ea0e25688e55a28dc7d95a67fe362f7537d6b1ce18890c95abf82ec37a0ac67f2191a127391309f568b
+DIST colorize-0.7.7.gem 15360 SHA256 d6ab95a5fcdea3c36c3327d38c1e79e2950ee1788506d8489ae35db330937a99 SHA512 ac55d281a3ac7aa72c02ecdc27a1936410cb2754e48e0c23b98eba5e98a8bf42e362fe3a86e73c12ff5445f2e0a92a7c561e82a4d85aae0ef08a9855b056f359 WHIRLPOOL 43576f9fcc4880644b610fcc7bbebf8c6a72381d40d33fc7c1d44f6145cc78998ad6bfcba3b5fb52ecb1fc9f15e1e2cf7973888a1bcf040597bb1b0abb8e9143
diff --git a/dev-ruby/colorize/colorize-0.7.5.ebuild b/dev-ruby/colorize/colorize-0.7.5.ebuild
new file mode 100644
index 000000000000..90938a68441c
--- /dev/null
+++ b/dev-ruby/colorize/colorize-0.7.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add some methods to set color, background color and text effect on console easier"
+HOMEPAGE="https://github.com/fazibear/colorize"
+LICENSE="GPL-2+"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ cd test || die
+ ${RUBY} test_colorize.rb || die
+}
diff --git a/dev-ruby/colorize/colorize-0.7.7.ebuild b/dev-ruby/colorize/colorize-0.7.7.ebuild
new file mode 100644
index 000000000000..3f7f1e5968d7
--- /dev/null
+++ b/dev-ruby/colorize/colorize-0.7.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add some methods to set color, background color and text effect on console easier"
+HOMEPAGE="https://github.com/fazibear/colorize"
+LICENSE="GPL-2+"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]ode[Cc]limate/d" test/test_colorize.rb || die
+}
+
+each_ruby_test() {
+ cd test || die
+ ${RUBY} test_colorize.rb || die
+}
diff --git a/dev-ruby/colorize/metadata.xml b/dev-ruby/colorize/metadata.xml
new file mode 100644
index 000000000000..f3a32c65e567
--- /dev/null
+++ b/dev-ruby/colorize/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">fazibear/colorize</remote-id>
+ </upstream>
+</pkgmetadata>