summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/http_parser_rb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/Manifest1
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild32
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild32
-rw-r--r--dev-ruby/http_parser_rb/metadata.xml8
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/Manifest b/dev-ruby/http_parser_rb/Manifest
new file mode 100644
index 000000000000..6e9a53d5b5a2
--- /dev/null
+++ b/dev-ruby/http_parser_rb/Manifest
@@ -0,0 +1 @@
+DIST http_parser.rb-0.6.0.gem 177664 SHA256 f11d0aec50ef26a7d1f991e627ac88acdb5979282aeba7a5c3be6ce0636ed196 SHA512 51c29bfc85de8cedb4e98fec84c955252556abaa4d0848fbc38b232879ffc946c72acf38440e8e9f1e31a8b734a68d43a96924af5f48ac4f1a054153ec913a08 WHIRLPOOL b3352eff85212f24fb3b283c44c448159e310235930671f7a732f9d41f4b3c111a390e0cd4b1d5a5cce41de88952f8c176bc761801de92b7877e46543e99cc72
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..2eb3a29098f3
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="http://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_http_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ruby_http_parser V=1
+ cp ext/ruby_http_parser/ruby_http_parser.so lib/ || die
+}
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild
new file mode 100644
index 000000000000..a46c275fbc5c
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="http://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_http_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ruby_http_parser V=1
+ cp ext/ruby_http_parser/ruby_http_parser.so lib/ || die
+}
diff --git a/dev-ruby/http_parser_rb/metadata.xml b/dev-ruby/http_parser_rb/metadata.xml
new file mode 100644
index 000000000000..0b03cf857be0
--- /dev/null
+++ b/dev-ruby/http_parser_rb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">tmm1/http_parser.rb</remote-id>
+ </upstream>
+</pkgmetadata>