summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/stomp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/stomp')
-rw-r--r--dev-ruby/stomp/Manifest2
-rw-r--r--dev-ruby/stomp/metadata.xml8
-rw-r--r--dev-ruby/stomp/stomp-1.3.2-r1.ebuild22
-rw-r--r--dev-ruby/stomp/stomp-1.3.2.ebuild22
-rw-r--r--dev-ruby/stomp/stomp-1.3.4.ebuild22
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-ruby/stomp/Manifest b/dev-ruby/stomp/Manifest
new file mode 100644
index 000000000000..ce072f4a944a
--- /dev/null
+++ b/dev-ruby/stomp/Manifest
@@ -0,0 +1,2 @@
+DIST stomp-1.3.2.gem 75264 SHA256 37ed903900f7abfcad0a714c0153632c97cb65de7c247c2a34f955c07ce174b4 SHA512 69142c2dae059f63d3cc2ac2ae5d9ccaceda84aa6b69a880325cbfc90f18774bc413a150449acc30fe66d932224731508a20e097f8c3a8c3dae7f636c41dbf94 WHIRLPOOL ad914a64050eb41f07ba760489fb952e811c9f094f30847f4f43b47f600b2b55968b481d93590375eea8c43c17469a9a401dd5e9d01a2d11294b224c22095a70
+DIST stomp-1.3.4.gem 77824 SHA256 adc77e8760236bd6d751991e0a4fc2bfd5443fc45dd5cfedb0d8c99273bc5897 SHA512 f141593a36bf45bcfa7254379fd88b78a62630eeebd638cea9e6e125d6cf5006632c96bcbdd6c0def0cea8f5fe7af11925d372d1e1fb3f1ee802c1a1023e2f15 WHIRLPOOL e1ac18aa1272e3cc59ab98c415c55e719437dbeb1fe13d07692564c636b08516d0be60570baa31973adf80c52fcc3017d7a7490daba737cac9f229811d402eab
diff --git a/dev-ruby/stomp/metadata.xml b/dev-ruby/stomp/metadata.xml
new file mode 100644
index 000000000000..2763c698229c
--- /dev/null
+++ b/dev-ruby/stomp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">stompgem/stomp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stomp/stomp-1.3.2-r1.ebuild b/dev-ruby/stomp/stomp-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..7a0b39bc9689
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.3.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-ruby/stomp/stomp-1.3.2.ebuild b/dev-ruby/stomp/stomp-1.3.2.ebuild
new file mode 100644
index 000000000000..d8605b94618c
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
diff --git a/dev-ruby/stomp/stomp-1.3.4.ebuild b/dev-ruby/stomp/stomp-1.3.4.ebuild
new file mode 100644
index 000000000000..7a0b39bc9689
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.3.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""