summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-31 23:24:58 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-02 16:13:45 +0000
commit1f1d0d72b8a6afea69473303c5002ab489e9852c (patch)
treefda4440f9a9faab57316e2d60bb9fde76f9f8d09 /dev-util/bazel/bazel-0.4.3.ebuild
parentsci-libs/sundials: initial import (diff)
downloadgentoo-1f1d0d72b8a6afea69473303c5002ab489e9852c.tar.gz
gentoo-1f1d0d72b8a6afea69473303c5002ab489e9852c.tar.bz2
gentoo-1f1d0d72b8a6afea69473303c5002ab489e9852c.zip
dev-util/bazel: version bump
Switched to the "dist" version to allow bootstraping. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/bazel/bazel-0.4.3.ebuild')
-rw-r--r--dev-util/bazel/bazel-0.4.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/bazel/bazel-0.4.3.ebuild b/dev-util/bazel/bazel-0.4.3.ebuild
new file mode 100644
index 000000000000..09ffca6720cc
--- /dev/null
+++ b/dev-util/bazel/bazel-0.4.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ doins -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ doins -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}