summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-15 23:49:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-16 00:12:15 +0100
commit3785c594bec3e9e3ae518ad1f13cf7bca16c1f69 (patch)
tree8f9d785a07c06a119e1d890b888c8e853f0d0db7 /dev-util/mdds/mdds-9999.ebuild
parentapp-text/libodfgen: 0.1.7 version bump (diff)
downloadgentoo-3785c594bec3e9e3ae518ad1f13cf7bca16c1f69.tar.gz
gentoo-3785c594bec3e9e3ae518ad1f13cf7bca16c1f69.tar.bz2
gentoo-3785c594bec3e9e3ae518ad1f13cf7bca16c1f69.zip
dev-util/mdds: EAPI-7 bump
Rebase buildsystem patch. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds/mdds-9999.ebuild')
-rw-r--r--dev-util/mdds/mdds-9999.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 65b5df3e9c0e..facdbc17f0d4 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3"
-
-inherit autotools toolchain-funcs ${GITECLASS}
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
-[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
LICENSE="MIT"
SLOT="1/${PV%.*}"
IUSE="doc valgrind"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
RDEPEND="dev-libs/boost:="
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? (
app-doc/doxygen
dev-python/sphinx
@@ -28,7 +29,7 @@ DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )
"
-PATCHES=( "${FILESDIR}/${PN}-1.4.1-buildsystem.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.4.3-buildsystem.patch" )
src_prepare(){
default