summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-08 23:18:21 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-08 23:52:01 +0100
commit7126312f845d1535f401e25f3c60fc74f7a209f4 (patch)
treeb2f0d6c3b86336f441c0d5fbcb8066eb9c450d59 /dev-util/opencl-headers
parentgames-engines/odamex: Drop old 0.8.1-r1 (diff)
downloadgentoo-7126312f845d1535f401e25f3c60fc74f7a209f4.tar.gz
gentoo-7126312f845d1535f401e25f3c60fc74f7a209f4.tar.bz2
gentoo-7126312f845d1535f401e25f3c60fc74f7a209f4.zip
dev-util/opencl-headers: install directly into /usr/include
These cannot be in /usr/lib/OpenCL/vendor/... because eselect-opencl doesn't know how to handle unified headers, resulting in build failures due to missing header files. Seeing as we are planning to deprecate eselect-opencl soon anyway, adapt this and opencl-icd-loader to the new approach so that they can be used for transition testing without breaking the more established ICD loader i.e. ocl-icd. Note that this WILL cause massive dependency issues until opencl-icd-loader has been added to virtual/opencl. Use with caution. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util/opencl-headers')
-rw-r--r--dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild (renamed from dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild)15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild b/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
index 0c64e9cc994a..917c0cad3500 100644
--- a/dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild
+++ b/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=7
-inherit multilib-minimal
-
MY_PN="OpenCL-Headers"
MY_P="${MY_PN}-${PV}"
@@ -16,14 +14,13 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# To avoid file collisions in /usr/include/CL/
+DEPEND="!app-eselect/eselect-opencl"
+RDEPEND="${DEPEND}"
+
S="${WORKDIR}/${MY_P}"
-multilib_src_install() {
- # Ideally we would install these directly into /usr/include but that would conflict
- # with eselect-opencl, therefore we install these into the vendor directory used by
- # dev-libs/opencl-icd-loader. Hopefully we will get this resolved soon and we can
- # stop messing with multilib in this package.
- local ocl_dir="/usr/$(get_libdir)/OpenCL/vendors/opencl-icd-loader"
- insinto "${ocl_dir}"/include
+src_install() {
+ insinto /usr/include
doins -r "${S}"/CL
}