summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/sgb/sgb-20030623.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/sgb/sgb-20030623.ebuild')
-rw-r--r--dev-util/sgb/sgb-20030623.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/sgb/sgb-20030623.ebuild b/dev-util/sgb/sgb-20030623.ebuild
new file mode 100644
index 000000000000..a3bef58406f8
--- /dev/null
+++ b/dev-util/sgb/sgb-20030623.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+DESCRIPTION="Stanford GraphBase"
+HOMEPAGE="ftp://labrea.stanford.edu/pub/sgb/"
+SRC_URI="ftp://labrea.stanford.edu/pub/sgb/sgb-${PV:0:4}-${PV:4:2}-${PV:6:2}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+DEPEND="|| ( >=dev-util/cweb-3.00 virtual/tex-base )"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/sgb-20030623-parallel-make-fix.patch
+ epatch "${FILESDIR}"/sgb-20030623-destdir.patch
+}
+
+src_compile() {
+ # bug #299028
+ emake -j1 \
+ CFLAGS="${CFLAGS}" \
+ SGBDIR=/usr/share/${PN} \
+ INCLUDEDIR=/usr/include/sgb \
+ LIBDIR=/usr/$(get_libdir) \
+ BINDIR=/usr/bin \
+ CFLAGS="${CFLAGS}" \
+ lib demos tests || die "Failed to build"
+ #CWEBINPUTS=/usr/share/${PN}/cweb \
+ #LDFLAGS="${LDFLAGS}" \
+}
+
+src_install() {
+ dodir /usr/share/${PN} /usr/include/sgb /usr/lib /usr/bin /usr/share/${PN}/cweb
+ emake \
+ DESTDIR="${D}" \
+ SGBDIR=/usr/share/${PN} \
+ INCLUDEDIR=/usr/include/sgb \
+ LIBDIR=/usr/$(get_libdir) \
+ BINDIR=/usr/bin \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CWEBINPUTS=/usr/share/${PN}/cweb \
+ install \
+ || die "Failed to install"
+
+ # we don't need no makefile
+ rm "${D}"/usr/include/sgb/Makefile
+
+ dodoc ERRATA README
+}
+
+src_test() {
+ emake tests
+}