summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-05 18:41:33 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-05 18:41:45 +0100
commita306a8927c38add6a043238c426add96cc66fb7f (patch)
tree6ce41c6ba59bf3a3f3a153e67a8b5350724d3b28 /dev-util/strace
parentnet-nds/phpldapadmin: Drop vulnerable releases. (diff)
downloadgentoo-a306a8927c38add6a043238c426add96cc66fb7f.tar.gz
gentoo-a306a8927c38add6a043238c426add96cc66fb7f.tar.bz2
gentoo-a306a8927c38add6a043238c426add96cc66fb7f.zip
dev-util/strace: do not copy CFLAGS to CFLAGS_FOR_{M32,MX32}
Closes: https://bugs.gentoo.org/701516 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/files/strace-5.4-fix-LTO-CFLAGS-handling.patch24
-rw-r--r--dev-util/strace/strace-5.4.ebuild8
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-util/strace/files/strace-5.4-fix-LTO-CFLAGS-handling.patch b/dev-util/strace/files/strace-5.4-fix-LTO-CFLAGS-handling.patch
new file mode 100644
index 000000000000..0f277962b958
--- /dev/null
+++ b/dev-util/strace/files/strace-5.4-fix-LTO-CFLAGS-handling.patch
@@ -0,0 +1,24 @@
+Based on 52ac53e96143f6aac52738f6e385f75203a68a7b
+[PATCH] configure.ac: do not copy CFLAGS to CFLAGS_FOR_{M32,MX32}
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -984,11 +984,14 @@ AS_IF([test x$arch = xaarch64],
+ ])
+ ])
+
+-# Setting default compiler variables for personalities
++# Set default compiler variables for personalities.
+ m4_foreach([pers], [M32, MX32], dnl
+- [m4_foreach([var], [CC, CPP, CFLAGS, CPPFLAGS], dnl
+- [[: ${]var[_FOR_]pers[=$]var[}]
+- AC_SUBST(var[_FOR_]pers)])])
++ [m4_foreach([var], [CC, CPP, CPPFLAGS], dnl
++ [[: ${]var[_FOR_]pers[=$]var[}]
++ AC_SUBST(var[_FOR_]pers)]) dnl
++ m4_foreach([var], [CFLAGS], dnl
++ [[: ${]var[_FOR_]pers[=][}]
++ AC_SUBST(var[_FOR_]pers)])])
+
+ st_MPERS([m32], [aarch64|powerpc64|s390x|sparc64|tile|x32|x86_64])
+ st_MPERS([mx32], [x86_64])
diff --git a/dev-util/strace/strace-5.4.ebuild b/dev-util/strace/strace-5.4.ebuild
index db378889c0d5..31a56378b3f8 100644
--- a/dev-util/strace/strace-5.4.ebuild
+++ b/dev-util/strace/strace-5.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs autotools
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
@@ -37,9 +37,15 @@ RDEPEND="
perl? ( dev-lang/perl )
"
+PATCHES=( "${FILESDIR}"/${P}-fix-LTO-CFLAGS-handling.patch )
+
src_prepare() {
default
+ # Needed for applied patch (#701516). Remove with next version.
+ # Don't forget about autotools inherit.
+ eautoreconf
+
if [[ ! -e configure ]] ; then
# git generation
sed /autoreconf/d -i bootstrap || die