summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-23 01:33:38 +0100
committerSam James <sam@gentoo.org>2022-09-23 01:33:38 +0100
commit67f85e89af54f691503c47935fe4dd4671f41259 (patch)
tree9ee6b8acd552bc82b4674f2917f2d04a65bf70b7 /dev-util
parentapp-arch/zstd: add missing sys-libs/zlib dep (diff)
downloadgentoo-67f85e89af54f691503c47935fe4dd4671f41259.tar.gz
gentoo-67f85e89af54f691503c47935fe4dd4671f41259.tar.bz2
gentoo-67f85e89af54f691503c47935fe4dd4671f41259.zip
dev-util/ctags: fix automagic seccomp dep
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ctags/ctags-20220828.0-r1.ebuild (renamed from dev-util/ctags/ctags-20220828.0.ebuild)4
-rw-r--r--dev-util/ctags/ctags-99999999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/ctags/ctags-20220828.0.ebuild b/dev-util/ctags/ctags-20220828.0-r1.ebuild
index ceadc8424f8a..22b038adf5a8 100644
--- a/dev-util/ctags/ctags-20220828.0.ebuild
+++ b/dev-util/ctags/ctags-20220828.0-r1.ebuild
@@ -21,12 +21,13 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="json pcre test xml yaml"
+IUSE="json pcre seccomp test xml yaml"
RESTRICT="!test? ( test )"
DEPEND="
json? ( dev-libs/jansson:= )
pcre? ( dev-libs/libpcre2 )
+ seccomp? ( sys-libs/libseccomp )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"
@@ -57,6 +58,7 @@ src_configure() {
econf \
$(use_enable json) \
$(use_enable pcre pcre2) \
+ $(use_enable seccomp) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-etags \
diff --git a/dev-util/ctags/ctags-99999999.ebuild b/dev-util/ctags/ctags-99999999.ebuild
index ceadc8424f8a..22b038adf5a8 100644
--- a/dev-util/ctags/ctags-99999999.ebuild
+++ b/dev-util/ctags/ctags-99999999.ebuild
@@ -21,12 +21,13 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="json pcre test xml yaml"
+IUSE="json pcre seccomp test xml yaml"
RESTRICT="!test? ( test )"
DEPEND="
json? ( dev-libs/jansson:= )
pcre? ( dev-libs/libpcre2 )
+ seccomp? ( sys-libs/libseccomp )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"
@@ -57,6 +58,7 @@ src_configure() {
econf \
$(use_enable json) \
$(use_enable pcre pcre2) \
+ $(use_enable seccomp) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-etags \