summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-29 15:12:19 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-29 15:15:17 -0400
commitae5dc52c91c6085a54a3454e218a088dcfe39c95 (patch)
tree29f7bbce31ec8b5450cc0e2fa956d7c4198d6cc8 /dev-util
parentdev-util/strace: skip flaky -k test #545812 (diff)
downloadgentoo-ae5dc52c91c6085a54a3454e218a088dcfe39c95.tar.gz
gentoo-ae5dc52c91c6085a54a3454e218a088dcfe39c95.tar.bz2
gentoo-ae5dc52c91c6085a54a3454e218a088dcfe39c95.zip
dev-util/strace: add USE=unwind to control libunwind usage
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/metadata.xml3
-rw-r--r--dev-util/strace/strace-4.10.ebuild13
-rw-r--r--dev-util/strace/strace-4.9.ebuild12
-rw-r--r--dev-util/strace/strace-9999.ebuild13
4 files changed, 32 insertions, 9 deletions
diff --git a/dev-util/strace/metadata.xml b/dev-util/strace/metadata.xml
index 392a501dd31a..0ca954da6d5f 100644
--- a/dev-util/strace/metadata.xml
+++ b/dev-util/strace/metadata.xml
@@ -6,6 +6,9 @@
<flag name="aio">
Enable <pkg>dev-libs/libaio</pkg> support for tracing Asynchronous I/O operations
</flag>
+ <flag name="unwind">
+ Enable stack backtraces (-k flag) via <pkg>sys-libs/libunwind</pkg>
+ </flag>
</use>
<upstream>
<remote-id type="sourceforge">strace</remote-id>
diff --git a/dev-util/strace/strace-4.10.ebuild b/dev-util/strace/strace-4.10.ebuild
index dba2a1e53796..59e215bfb15f 100644
--- a/dev-util/strace/strace-4.10.ebuild
+++ b/dev-util/strace/strace-4.10.ebuild
@@ -19,12 +19,15 @@ HOMEPAGE="http://sourceforge.net/projects/strace/"
LICENSE="BSD"
SLOT="0"
-IUSE="aio perl static"
+IUSE="aio perl static unwind"
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
# strace only uses the header from libaio to decode structs
-DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
sys-kernel/linux-headers"
-RDEPEND="perl? ( dev-lang/perl )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )"
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
@@ -43,6 +46,10 @@ src_prepare() {
sed -i '1iexit 77' tests*/strace-k.test || die
}
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
src_install() {
default
use perl || rm "${ED}"/usr/bin/strace-graph
diff --git a/dev-util/strace/strace-4.9.ebuild b/dev-util/strace/strace-4.9.ebuild
index 287aa8b3dfb3..5fd2fd6c1a92 100644
--- a/dev-util/strace/strace-4.9.ebuild
+++ b/dev-util/strace/strace-4.9.ebuild
@@ -19,12 +19,14 @@ HOMEPAGE="http://sourceforge.net/projects/strace/"
LICENSE="BSD"
SLOT="0"
-IUSE="aio +perl static"
+IUSE="aio +perl static unwind"
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
# strace only uses the header from libaio to decode structs
-DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
sys-kernel/linux-headers"
-RDEPEND=""
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
@@ -40,6 +42,10 @@ src_prepare() {
export ac_cv_header_libaio_h=$(usex aio)
}
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
src_install() {
default
use perl || rm "${ED}"/usr/bin/strace-graph
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 8a1e0d6ef4c6..9a701506480b 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -19,12 +19,15 @@ HOMEPAGE="http://sourceforge.net/projects/strace/"
LICENSE="BSD"
SLOT="0"
-IUSE="aio perl static"
+IUSE="aio perl static unwind"
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
# strace only uses the header from libaio to decode structs
-DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
sys-kernel/linux-headers"
-RDEPEND="perl? ( dev-lang/perl )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )"
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
@@ -44,6 +47,10 @@ src_prepare() {
sed -i '1iexit 77' tests*/strace-k.test || die
}
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
src_install() {
default
use perl || rm "${ED}"/usr/bin/strace-graph