summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-action/supertuxkart
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-action/supertuxkart')
-rw-r--r--games-action/supertuxkart/supertuxkart-1.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-action/supertuxkart/supertuxkart-1.0.ebuild b/games-action/supertuxkart/supertuxkart-1.0.ebuild
index 96746c833f78..1f2999ac01bb 100644
--- a/games-action/supertuxkart/supertuxkart-1.0.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
HOMEPAGE="https://supertuxkart.net/"
@@ -56,7 +56,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# remove bundled libraries, just to be sure
rm -r lib/{angelscript,enet,glew,jpeglib,libpng,zlib} || die
@@ -78,11 +78,11 @@ src_configure() {
-DSTK_INSTALL_DATA_DIR=share/${PN}
-DBUILD_SHARED_LIBS=OFF # build bundled libsquish as static library
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc CHANGELOG.md
doicon -s 64 "${DISTDIR}"/${PN}.png