summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 18:18:26 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-14 12:26:33 -0500
commiteb9c7cfba76055dc8d6f13180a1c3a46dcc45404 (patch)
tree7d54d92f326c108dbc54b39fff70a7cc288aaea1 /games-board/cgoban/cgoban-1.9.14-r1.ebuild
parentgames-board/ccgo: remove deprecated games eclass (diff)
downloadgentoo-eb9c7cfba76055dc8d6f13180a1c3a46dcc45404.tar.gz
gentoo-eb9c7cfba76055dc8d6f13180a1c3a46dcc45404.tar.bz2
gentoo-eb9c7cfba76055dc8d6f13180a1c3a46dcc45404.zip
games-board/cgoban: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/cgoban/cgoban-1.9.14-r1.ebuild')
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-board/cgoban/cgoban-1.9.14-r1.ebuild b/games-board/cgoban/cgoban-1.9.14-r1.ebuild
new file mode 100644
index 000000000000..948c254910fc
--- /dev/null
+++ b/games-board/cgoban/cgoban-1.9.14-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="A Go-frontend"
+HOMEPAGE="http://cgoban1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_prepare() {
+ # ${P}-cflags.patch patches configure.ac, not .in:
+ mv configure.{in,ac} || die
+
+ default
+
+ cp cgoban_icon.png ${PN}.png || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ make_desktop_entry cgoban Cgoban
+}