summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-06-28 10:49:29 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-06-28 10:49:29 -0400
commit7efcd72291ba745978e8a02ca0ac6f8c07434a38 (patch)
tree7d0ce5edb3d6db86844a7eb00f0b01d1f2359851 /games-emulation/dosbox/dosbox-9999.ebuild
parentgames-strategy/0ad-data: update HOMEPAGE (diff)
downloadgentoo-7efcd72291ba745978e8a02ca0ac6f8c07434a38.tar.gz
gentoo-7efcd72291ba745978e8a02ca0ac6f8c07434a38.tar.bz2
gentoo-7efcd72291ba745978e8a02ca0ac6f8c07434a38.zip
Revert "games-emulation/dosbox: remove games eclass and convert to EAPI 6"
This reverts commit 3d239d4e470c8f0c99339649ec74c4bdf86cf98f.
Diffstat (limited to 'games-emulation/dosbox/dosbox-9999.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index 1c5c700e10af..f0caa33b0f3c 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
-inherit autotools eutils subversion
+inherit autotools eutils subversion games
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
@@ -15,8 +15,8 @@ KEYWORDS=""
IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
- debug? ( sys-libs/ncurses:0 )
opengl? ( virtual/glu virtual/opengl )
+ debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
@@ -30,13 +30,12 @@ src_unpack() {
}
src_prepare() {
- default
subversion_src_prepare
eautoreconf
}
src_configure() {
- econf \
+ egamesconf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
@@ -48,4 +47,5 @@ src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
+ prepgamesdirs
}