summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:38:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:11 +0200
commit6111aeb597fe9fa79a3d9f327fa915fe806ca4c2 (patch)
tree52dd9f345018cd2a8a9c3160bfae1522db54cba4 /games-emulation/pcsxr
parentdev-util/creduce: Port to cmake.eclass (diff)
downloadgentoo-6111aeb597fe9fa79a3d9f327fa915fe806ca4c2.tar.gz
gentoo-6111aeb597fe9fa79a3d9f327fa915fe806ca4c2.tar.bz2
gentoo-6111aeb597fe9fa79a3d9f327fa915fe806ca4c2.zip
games-emulation/pcsxr: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation/pcsxr')
-rw-r--r--games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild6
-rw-r--r--games-emulation/pcsxr/pcsxr-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild b/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
index 9f4570150ce9..f8d068fed3ca 100644
--- a/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
+++ b/games-emulation/pcsxr/pcsxr-1.9.94_p20190306.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
EGIT_COMMIT="62467b86871aee3d70c7445f3cb79f0858ec566e"
MY_P=${PN}-${EGIT_COMMIT}
@@ -70,11 +70,11 @@ src_configure() {
-DSND_BACKEND=${sound_backend}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
mv "${ED}"/usr/share/doc/pcsxr/* "${ED}/usr/share/doc/${PF}/" || die
rmdir "${ED}"/usr/share/doc/pcsxr || die
}
diff --git a/games-emulation/pcsxr/pcsxr-9999.ebuild b/games-emulation/pcsxr/pcsxr-9999.ebuild
index 10ae63ff0105..2066e487f6ef 100644
--- a/games-emulation/pcsxr/pcsxr-9999.ebuild
+++ b/games-emulation/pcsxr/pcsxr-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils git-r3 xdg-utils
+inherit cmake git-r3 xdg-utils
DESCRIPTION="PCSX-Reloaded: a fork of PCSX, the discontinued Playstation emulator"
HOMEPAGE="https://github.com/iCatButler/pcsxr"
@@ -67,11 +67,11 @@ src_configure() {
-DSND_BACKEND=${sound_backend}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
mv "${ED}"/usr/share/doc/pcsxr/* "${ED}/usr/share/doc/${PF}/" || die
rmdir "${ED}"/usr/share/doc/pcsxr || die
}