summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-mud/circlemud/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-mud/circlemud/files')
-rw-r--r--games-mud/circlemud/files/circlemud-3.1-ldflags.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-mud/circlemud/files/circlemud-3.1-ldflags.patch b/games-mud/circlemud/files/circlemud-3.1-ldflags.patch
new file mode 100644
index 000000000000..fc86e5e7056e
--- /dev/null
+++ b/games-mud/circlemud/files/circlemud-3.1-ldflags.patch
@@ -0,0 +1,65 @@
+--- src/Makefile.in.old 2010-09-16 12:19:26.000000000 +0200
++++ src/Makefile.in 2010-09-16 12:19:41.000000000 +0200
+@@ -54,7 +54,7 @@
+ $(MAKE) $(BINDIR)/circle
+
+ $(BINDIR)/circle : $(OBJFILES)
+- $(CC) -o $(BINDIR)/circle $(PROFILE) $(OBJFILES) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(BINDIR)/circle $(PROFILE) $(OBJFILES) $(LIBS)
+
+ clean:
+ rm -f *.o
+--- src/util/Makefile.in.old 2010-09-16 12:31:01.000000000 +0200
++++ src/util/Makefile.in 2010-09-16 12:32:08.000000000 +0200
+@@ -52,40 +52,40 @@
+
+ $(BINDIR)/autowiz: autowiz.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h $(INCDIR)/utils.h $(INCDIR)/db.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/autowiz autowiz.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/autowiz autowiz.c
+
+ $(BINDIR)/delobjs: delobjs.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h $(INCDIR)/utils.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/delobjs delobjs.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/delobjs delobjs.c
+
+ $(BINDIR)/listrent: listrent.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/listrent listrent.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/listrent listrent.c
+
+ $(BINDIR)/mudpasswd: mudpasswd.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h $(INCDIR)/utils.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/mudpasswd mudpasswd.c @CRYPTLIB@
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/mudpasswd mudpasswd.c @CRYPTLIB@
+
+ $(BINDIR)/play2to3: play2to3.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/play2to3 play2to3.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/play2to3 play2to3.c
+
+ $(BINDIR)/purgeplay: purgeplay.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h $(INCDIR)/utils.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/purgeplay purgeplay.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/purgeplay purgeplay.c
+
+ $(BINDIR)/shopconv: shopconv.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h $(INCDIR)/db.h $(INCDIR)/utils.h $(INCDIR)/shop.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/shopconv shopconv.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/shopconv shopconv.c
+
+ $(BINDIR)/showplay: showplay.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h \
+ $(INCDIR)/structs.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/showplay showplay.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/showplay showplay.c
+
+ $(BINDIR)/sign: sign.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/sign sign.c @NETLIB@
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/sign sign.c @NETLIB@
+
+ $(BINDIR)/split: split.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/split split.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/split split.c
+
+ $(BINDIR)/wld2html: wld2html.c $(INCDIR)/conf.h $(INCDIR)/sysdep.h
+- $(CC) $(CFLAGS) -o $(BINDIR)/wld2html wld2html.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $(BINDIR)/wld2html wld2html.c