summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2020-04-17 15:15:37 +0200
committerJames Le Cuirot <chewi@gentoo.org>2020-04-28 23:32:40 +0100
commitca29abac964537e3dc64a24105c99bbd77591e95 (patch)
treecad497e290d64cf19135ea42bde3a3099619a96d /games-puzzle
parentsys-firmware/intel-microcode: drop old (diff)
downloadgentoo-ca29abac964537e3dc64a24105c99bbd77591e95.tar.gz
gentoo-ca29abac964537e3dc64a24105c99bbd77591e95.tar.bz2
gentoo-ca29abac964537e3dc64a24105c99bbd77591e95.zip
games-puzzle/world-of-goo-hb-1.53: new package
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/world-of-goo-hb/Manifest1
-rw-r--r--games-puzzle/world-of-goo-hb/metadata.xml11
-rw-r--r--games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild62
3 files changed, 74 insertions, 0 deletions
diff --git a/games-puzzle/world-of-goo-hb/Manifest b/games-puzzle/world-of-goo-hb/Manifest
new file mode 100644
index 000000000000..eef31234b3fa
--- /dev/null
+++ b/games-puzzle/world-of-goo-hb/Manifest
@@ -0,0 +1 @@
+DIST WorldOfGoo.Linux.1.53.sh 196695812 BLAKE2B a357a5a25bece4cb93735881f345ff64d1f89c8a17aa9550edab29815f2187cad29eab9bae21c4c8aff06a4dd3fde64bddfb54fe96a7c94a04e82be6d8ed5129 SHA512 3f0e9122f7cf043d7a7ceabfe221b03d32d3c6627e022551917137f0d13fccf21d218d028a3765eaa93e0e65d41110be8091189c46a5bad1616505500ce4f6e6
diff --git a/games-puzzle/world-of-goo-hb/metadata.xml b/games-puzzle/world-of-goo-hb/metadata.xml
new file mode 100644
index 000000000000..b010f5d66be9
--- /dev/null
+++ b/games-puzzle/world-of-goo-hb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bundled-libs">Use bundled libs</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild b/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
new file mode 100644
index 000000000000..e9b72ddc39b5
--- /dev/null
+++ b/games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils # eutils for make_wrapper()
+
+MY_PN="WorldOfGoo"
+
+DESCRIPTION="A puzzle game with a strong emphasis on physics (HumbleBundle edition)"
+HOMEPAGE="http://2dboy.com/"
+SRC_URI="${MY_PN}.Linux.${PV}.sh"
+
+LICENSE="2dboy-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist strip bundled-libs? ( splitdebug )"
+
+DEPEND="app-arch/unzip"
+RDEPEND="!bundled-libs? (
+ media-libs/libsdl2[alsa,sound,opengl,video]
+ media-libs/sdl2-mixer[vorbis]
+ )
+ sys-libs/glibc
+ virtual/opengl
+ virtual/glu
+ >=sys-devel/gcc-3.4
+ !games-puzzle/world-of-goo
+ !games-puzzle/world-of-goo-gog"
+
+dir="/opt/${PN%-*}"
+
+QA_PREBUILT="${dir:1}/${MY_PN}.bin.x86
+ ${dir:1}/${MY_PN}.bin.x86_64"
+
+pkg_nofetch() {
+ elog "Download ${A} from www.humblebundle.com"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unzip -d "${S}" "${DISTDIR}/${A}"
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe data/x86$(usex amd64 _64)/${MY_PN}.bin.x86$(usex amd64 _64)
+
+ make_wrapper ${PN%-*} "${dir}"/${MY_PN}.bin.x86$(usex amd64 _64) \
+ $(use bundled-libs && (printf '"%s" "%s/lib%s"' "${dir}" "${dir}" $(usex amd64 64) || die))
+
+ insinto "${dir}"
+ doins -r data/noarch/game
+ use bundled-libs && doins -r data/x86$(usex amd64 _64)/lib$(usex amd64 64)
+ newicon data/noarch/game/gooicon.png ${PN%-*}.png
+
+ make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}
+
+ docinto html
+ dodoc data/noarch/readme.html
+}