summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-02 21:19:30 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-02 21:19:36 +0100
commitd4639706abcb52d2cc0f90a1eb73adfb0a9cea11 (patch)
tree05ed00ad40155fa730250e72ab7fc5761da21019 /games-puzzle
parentdev-db/pgpool2: remove libressl support (diff)
downloadgentoo-d4639706abcb52d2cc0f90a1eb73adfb0a9cea11.tar.gz
gentoo-d4639706abcb52d2cc0f90a1eb73adfb0a9cea11.tar.bz2
gentoo-d4639706abcb52d2cc0f90a1eb73adfb0a9cea11.zip
games-puzzle/xwelltris: tweak for gcc-11
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/739318 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch11
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch b/games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch
new file mode 100644
index 000000000000..0398bfec4359
--- /dev/null
+++ b/games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch
@@ -0,0 +1,11 @@
+--- a/src/sdl/sdlwelldrawing.cxx
++++ b/src/sdl/sdlwelldrawing.cxx
+@@ -72,7 +72,7 @@ void SDLWellDrawingEngine::init(int inum_fields, int idx, int idy,
+
+ fields[i]=SDL_DisplayFormat(surface);
+ SDL_FreeSurface(surface);
+- if(fields[i]>0)
++ if(fields[i])
+ clear_field(i);
+ }
+ bg_color=colors[BackColor];
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 36c39e67014c..11369637b0b0 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -25,6 +25,7 @@ RDEPEND="
PATCHES=(
# Look in ${EPREFIX}/var/lib/xwelltris for score file
"${FILESDIR}"/${PN}-1.0.1-scorefile-dir.patch
+ "${FILESDIR}"/${PN}-1.0.1-gcc-11.patch
)
src_prepare() {