summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch11
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch b/games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch
new file mode 100644
index 000000000000..0398bfec4359
--- /dev/null
+++ b/games-puzzle/xwelltris/files/xwelltris-1.0.1-gcc-11.patch
@@ -0,0 +1,11 @@
+--- a/src/sdl/sdlwelldrawing.cxx
++++ b/src/sdl/sdlwelldrawing.cxx
+@@ -72,7 +72,7 @@ void SDLWellDrawingEngine::init(int inum_fields, int idx, int idy,
+
+ fields[i]=SDL_DisplayFormat(surface);
+ SDL_FreeSurface(surface);
+- if(fields[i]>0)
++ if(fields[i])
+ clear_field(i);
+ }
+ bg_color=colors[BackColor];
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 36c39e67014c..11369637b0b0 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -25,6 +25,7 @@ RDEPEND="
PATCHES=(
# Look in ${EPREFIX}/var/lib/xwelltris for score file
"${FILESDIR}"/${PN}-1.0.1-scorefile-dir.patch
+ "${FILESDIR}"/${PN}-1.0.1-gcc-11.patch
)
src_prepare() {