summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-09-09 19:13:56 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-02 09:41:15 +0300
commitc91384e531b2f1e92cc987c2fefa85d49158a844 (patch)
treefab18af9cf70f37f24d184d4c3e7f951e1e03183 /games-rpg/adonthell/adonthell-0.3.8.ebuild
parentdev-libs/libucl: remove failing tests (diff)
downloadgentoo-c91384e531b2f1e92cc987c2fefa85d49158a844.tar.gz
gentoo-c91384e531b2f1e92cc987c2fefa85d49158a844.tar.bz2
gentoo-c91384e531b2f1e92cc987c2fefa85d49158a844.zip
games-rpg/adonthell: update to 0.3.8
Migrated to python3, EAPI7, update license to GPL-2+. Closes: https://bugs.gentoo.org/680762 Closes: https://bugs.gentoo.org/735356 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-rpg/adonthell/adonthell-0.3.8.ebuild')
-rw-r--r--games-rpg/adonthell/adonthell-0.3.8.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-rpg/adonthell/adonthell-0.3.8.ebuild b/games-rpg/adonthell/adonthell-0.3.8.ebuild
new file mode 100644
index 000000000000..ee5853868fc4
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+DESCRIPTION="Roleplaying game engine"
+HOMEPAGE="http://adonthell.nongnu.org/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libsdl2[X,video,sound]
+ media-libs/libvorbis
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-ttf
+ sys-libs/zlib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS NEWBIE NEWS README )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --program-transform-name="s:${PN}-$(ver_cut 1-2):${PN}:" \
+ --disable-py-debug \
+ --with-python=${EPYTHON} \
+ $(use_enable nls) \
+ $(use_enable doc)
+}