summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-03-03 17:45:35 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-03-06 22:34:58 +0000
commitbed5ab3bc1fc1c4de95067bf365c861a52e24c61 (patch)
tree08f0881bc2a0b2a52930cb590b18dbd59cf7d6a5 /games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
parentsys-kernel/linux-headers: package arch/*/kernel/syscalls, bug #679630 (diff)
downloadgentoo-bed5ab3bc1fc1c4de95067bf365c861a52e24c61.tar.gz
gentoo-bed5ab3bc1fc1c4de95067bf365c861a52e24c61.tar.bz2
gentoo-bed5ab3bc1fc1c4de95067bf365c861a52e24c61.zip
games-simulation/lincity-ng: bump version to 2.9_beta; EAPI=7
Drop games eclass; update homepage, SRC_URI and licenses; fix prefixed install; some minor and stylistic changes. Closes: https://bugs.gentoo.org/604618 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11235 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild')
-rw-r--r--games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild b/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
new file mode 100644
index 000000000000..c71738c6f41b
--- /dev/null
+++ b/games-simulation/lincity-ng/lincity-ng-2.9_beta.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="City simulation game"
+HOMEPAGE="https://github.com/lincity-ng/lincity-ng"
+SRC_URI="https://github.com/lincity-ng/lincity-ng/archive/lincity-ng-${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BitstreamVera CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-games/physfs
+ dev-libs/libxml2:2
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/ftjam
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P/_/-}"
+
+src_prepare() {
+ default
+ sed -i "/COPYING COPYING-data.txt COPYING-fonts.txt CREDITS /d" \
+ Jamfile || die
+ ./autogen.sh || die
+}
+
+src_compile() {
+ jam -q -dx -j $(makeopts_jobs) || die "jam failed"
+}
+
+src_install() {
+ jam -sDESTDIR="${D}" \
+ -sappdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ -sapplicationsdir="${EPREFIX}/usr/share/applications" \
+ -spixmapsdir="${EPREFIX}/usr/share/pixmaps" \
+ install \
+ || die "jam install failed"
+}