summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 11:07:40 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:24:10 +0200
commit1f2d5043f5d0643f6be725719c2cf0d7283d2551 (patch)
tree000bba8ca927191b48e1975abb97760e4168d690 /games-sports/ski
parentgames-server/cyphesis: [QA] Add missing python metadata variables (diff)
downloadgentoo-1f2d5043f5d0643f6be725719c2cf0d7283d2551.tar.gz
gentoo-1f2d5043f5d0643f6be725719c2cf0d7283d2551.tar.bz2
gentoo-1f2d5043f5d0643f6be725719c2cf0d7283d2551.zip
games-sports/ski: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'games-sports/ski')
-rw-r--r--games-sports/ski/ski-6.8.ebuild9
-rw-r--r--games-sports/ski/ski-6.9-r1.ebuild13
-rw-r--r--games-sports/ski/ski-6.9.ebuild9
3 files changed, 18 insertions, 13 deletions
diff --git a/games-sports/ski/ski-6.8.ebuild b/games-sports/ski/ski-6.8.ebuild
index 2f6f37632bda..fdb1608a108e 100644
--- a/games-sports/ski/ski-6.8.ebuild
+++ b/games-sports/ski/ski-6.8.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit python-single-r1 games
DESCRIPTION="A simple text-mode skiing game"
@@ -13,9 +15,10 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=""
-RDEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
pkg_setup() {
games_pkg_setup
diff --git a/games-sports/ski/ski-6.9-r1.ebuild b/games-sports/ski/ski-6.9-r1.ebuild
index e61049424ece..a18d0d0158cf 100644
--- a/games-sports/ski/ski-6.9-r1.ebuild
+++ b/games-sports/ski/ski-6.9-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python2_7 )
+
inherit eutils python-single-r1
DESCRIPTION="A simple text-mode skiing game"
@@ -13,13 +15,10 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=""
-RDEPEND=""
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
src_install() {
dobin ski
diff --git a/games-sports/ski/ski-6.9.ebuild b/games-sports/ski/ski-6.9.ebuild
index 6159ddd70bb4..146c838b59fd 100644
--- a/games-sports/ski/ski-6.9.ebuild
+++ b/games-sports/ski/ski-6.9.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit python-single-r1 games
DESCRIPTION="A simple text-mode skiing game"
@@ -13,9 +15,10 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=""
-RDEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
pkg_setup() {
games_pkg_setup