summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 23:23:34 +0000
committerSam James <sam@gentoo.org>2021-04-05 23:24:34 +0000
commit44408c23a81c88f99ab2ea6a94bae01f1a3e2f19 (patch)
tree11d196ce8535fdb73dce71274b9d9b0358cdde42 /games-util/antimicro
parentgames-util/antimicro: port to cmake.eclass (cmake-utils--), fix compressed man (diff)
downloadgentoo-44408c23a81c88f99ab2ea6a94bae01f1a3e2f19.tar.gz
gentoo-44408c23a81c88f99ab2ea6a94bae01f1a3e2f19.tar.bz2
gentoo-44408c23a81c88f99ab2ea6a94bae01f1a3e2f19.zip
games-util/antimicro: include SDL 2 patch
Not clear why this doesn't happen for me, but it happened for toralf and a user, which is good enough. Patch is straightforward. Thanks-to: Tim Barnes <tim.barnes@gmail.com> Closes: https://bugs.gentoo.org/649242 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util/antimicro')
-rw-r--r--games-util/antimicro/antimicro-2.23.ebuild1
-rw-r--r--games-util/antimicro/files/antimicro-2.23-SDL2-include.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/games-util/antimicro/antimicro-2.23.ebuild b/games-util/antimicro/antimicro-2.23.ebuild
index 13efec5688b0..1363ec031a9d 100644
--- a/games-util/antimicro/antimicro-2.23.ebuild
+++ b/games-util/antimicro/antimicro-2.23.ebuild
@@ -31,6 +31,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-linking-errors.patch
"${FILESDIR}"/${PN}-2.23-no-compress-man-page.patch
+ "${FILESDIR}"/${PN}-2.23-SDL2-include.patch
)
src_prepare() {
diff --git a/games-util/antimicro/files/antimicro-2.23-SDL2-include.patch b/games-util/antimicro/files/antimicro-2.23-SDL2-include.patch
new file mode 100644
index 000000000000..a71e9b4b862a
--- /dev/null
+++ b/games-util/antimicro/files/antimicro-2.23-SDL2-include.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/649242
+Thanks-to: Tim Barnes
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -585,6 +585,7 @@
+ endif(WITH_XTEST)
+
+ if(USE_SDL_2)
++ include_directories(${SDL2_INCLUDE_DIRS})
+ list(APPEND LIBS ${SDL2_LIBRARIES})
+ else()
+ list(APPEND LIBS ${SDL_LIBRARIES})