summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-20 23:17:20 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-24 01:00:24 +0200
commit085e1f8e9cf79de031b7bf93e2b0327e58253793 (patch)
treeec7e595f627b5206ee02719adc0d847dbe317864 /gnome-base/dconf-editor/dconf-editor-3.22.1.ebuild
parentapp-text/evince: cleanup old revision (diff)
downloadgentoo-085e1f8e9cf79de031b7bf93e2b0327e58253793.tar.gz
gentoo-085e1f8e9cf79de031b7bf93e2b0327e58253793.tar.bz2
gentoo-085e1f8e9cf79de031b7bf93e2b0327e58253793.zip
gnome-base/dconf-editor: version bump 3.20.3 → 3.22.1
Package-Manager: portage-2.3.1
Diffstat (limited to 'gnome-base/dconf-editor/dconf-editor-3.22.1.ebuild')
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.22.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/dconf-editor-3.22.1.ebuild b/gnome-base/dconf-editor/dconf-editor-3.22.1.ebuild
new file mode 100644
index 000000000000..d82c8ec6e298
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.22.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://git.gnome.org/browse/dconf-editor"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+COMMON_DEPEND="
+ dev-libs/appstream-glib
+ >=dev-libs/glib-2.46.0:2
+ >=gnome-base/dconf-0.25.1
+ >=x11-libs/gtk+-3.21.6:3
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/dconf-0.22[X]
+"
+
+src_configure() {
+ gnome2_src_configure \
+ VALAC="$(type -P true)"
+}