summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/sushi/sushi-3.12.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/sushi/sushi-3.12.0.ebuild')
-rw-r--r--gnome-extra/sushi/sushi-3.12.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/sushi/sushi-3.12.0.ebuild b/gnome-extra/sushi/sushi-3.12.0.ebuild
new file mode 100644
index 000000000000..834f65ddc349
--- /dev/null
+++ b/gnome-extra/sushi/sushi-3.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="http://git.gnome.org/browse/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="office"
+
+# Optional app-office/unoconv support (OOo to pdf)
+# freetype needed for font loader
+# libX11 needed for sushi_create_foreign_window()
+COMMON_DEPEND="
+ >=x11-libs/gdk-pixbuf-2.23[introspection]
+ >=dev-libs/gjs-1.40
+ >=dev-libs/glib-2.29.14:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=media-libs/clutter-1.11.4:1.0[introspection]
+ >=media-libs/clutter-gtk-1.0.1:1.0[introspection]
+ >=x11-libs/gtk+-3.4.0:3[introspection]
+
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/clutter-gst:2.0[introspection]
+ media-libs/musicbrainz:5
+ net-libs/webkit-gtk:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/libX11
+
+ office? ( app-office/unoconv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ x11-themes/gnome-icon-theme-symbolic
+"
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}