summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-11-11 15:07:21 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-13 16:04:13 -0500
commitaea321df04b691e96bf200a08ac95157dea77e53 (patch)
tree03ef56543243e646e9c23f008894f216a7f0d689 /gui-apps
parentgui-apps/wcm: version bump to 0.6.0 (diff)
downloadgentoo-aea321df04b691e96bf200a08ac95157dea77e53.tar.gz
gentoo-aea321df04b691e96bf200a08ac95157dea77e53.tar.bz2
gentoo-aea321df04b691e96bf200a08ac95157dea77e53.zip
gui-apps/wayland-logout: new dependency for wf-shell
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wayland-logout/Manifest1
-rw-r--r--gui-apps/wayland-logout/metadata.xml12
-rw-r--r--gui-apps/wayland-logout/wayland-logout-1.0.ebuild26
-rw-r--r--gui-apps/wayland-logout/wayland-logout-9999.ebuild26
4 files changed, 65 insertions, 0 deletions
diff --git a/gui-apps/wayland-logout/Manifest b/gui-apps/wayland-logout/Manifest
new file mode 100644
index 000000000000..abc4336a7b56
--- /dev/null
+++ b/gui-apps/wayland-logout/Manifest
@@ -0,0 +1 @@
+DIST wayland-logout-1.0.tar.gz 16663 BLAKE2B 7f8932342cd584f9e8c6abcaf83b2a5ff7ff14eda00f6d47a402206cff5786a9f4d5fbd75b8704fd0c39fad9550e47dbd499ac4a9b233f63ee6ed80b544d4556 SHA512 2c31fe11d4e6de53c7e873e7d235c4dcfbcb1425f4d7d2969b623574dd0bea77ee1fd482949b09cd86a1755ed48f2a8b39e4b2db6adedaf6d465144e9ef71652
diff --git a/gui-apps/wayland-logout/metadata.xml b/gui-apps/wayland-logout/metadata.xml
new file mode 100644
index 000000000000..d155fdbc0406
--- /dev/null
+++ b/gui-apps/wayland-logout/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wayland-logout/wayland-logout-1.0.ebuild b/gui-apps/wayland-logout/wayland-logout-1.0.ebuild
new file mode 100644
index 000000000000..edb385b32abf
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ dosym wayland-logout /usr/bin/wlogout
+}
diff --git a/gui-apps/wayland-logout/wayland-logout-9999.ebuild b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
new file mode 100644
index 000000000000..edb385b32abf
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ dosym wayland-logout /usr/bin/wlogout
+}