summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-04 16:35:59 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-04 16:36:24 +0200
commitc933d829abca11b8909587fa14ce82e24dd175d5 (patch)
tree99474411f0322bb9d9e13e5c630bc0610287a102 /mail-client
parentwww-client/firefox: don't pass -g* value from FLAGS when not using CLANG (diff)
downloadgentoo-c933d829abca11b8909587fa14ce82e24dd175d5.tar.gz
gentoo-c933d829abca11b8909587fa14ce82e24dd175d5.tar.bz2
gentoo-c933d829abca11b8909587fa14ce82e24dd175d5.zip
mail-client/thunderbird: don't pass -g* value from FLAGS when not using CLANG
Closes: https://bugs.gentoo.org/721126 Closes: https://bugs.gentoo.org/746506 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-78.3.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail-client/thunderbird/thunderbird-78.3.1.ebuild b/mail-client/thunderbird/thunderbird-78.3.1.ebuild
index 16934b765b02..ffd926e975ba 100644
--- a/mail-client/thunderbird/thunderbird-78.3.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-78.3.1.ebuild
@@ -561,7 +561,11 @@ src_configure() {
mozconfig_add_options_ac '+debug' --disable-optimize
else
if is-flag '-g*' ; then
- mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ if use clang ; then
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ else
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols
+ fi
else
mozconfig_add_options_ac 'Gentoo default' --disable-debug-symbols
fi