summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:15 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:02:06 -0400
commit32fc9a3a1dcac868c5ca1f057e4e2acf06253637 (patch)
treebaca8fe2ac4123c5fd66f77cd86a7d2eb1c3b4d3 /mate-base
parentmate-base/mate-menus: remove unnecessary postinst (diff)
downloadgentoo-32fc9a3a1dcac868c5ca1f057e4e2acf06253637.tar.gz
gentoo-32fc9a3a1dcac868c5ca1f057e4e2acf06253637.tar.bz2
gentoo-32fc9a3a1dcac868c5ca1f057e4e2acf06253637.zip
mate-base/mate-panel: bump to 1.22.1, fix deps and wayland support
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.22.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index cfc5af62b3fd..1fc4cb3f8ca7 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.22.0.tar.xz 2251040 BLAKE2B 6a4da6080cec2fc7858c711fa0a2c7497f4d03a1e22394f481925be32b17f7905920d4155ca75b9bf0d6bbf4af078aac77abc99e6d5a22e84bf453e2290ba032 SHA512 078c6dcdc17970a7a7fab9a218eaf2c8cd6c4074c0c23ff4ce7ccf57e007d0afcbe797be4ad4c9d2c16d9033cc554cc5a979ec61dc721514db939a5e60de456b
+DIST mate-panel-1.22.1.tar.xz 2142620 BLAKE2B 3b105c04cd2c1bf0c5077fb79dc8f0fea090eca96b766567a3921c25d35f915d36446ad765fd226f2fc2a70d4c95987a1c503bd60a92210f944fb50a83bc6a90 SHA512 023599a2c0a879e32df11fc09d7526a54b8dc5248173c940e61df1dd9cbe8c04e4c916da89f5a64e44fe3f99462d56c72849314fc182c0af58a7c19e1fac642f
diff --git a/mate-base/mate-panel/mate-panel-1.22.1.ebuild b/mate-base/mate-panel/mate-panel-1.22.1.ebuild
new file mode 100644
index 000000000000..fdfc53f24428
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.22.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection wayland"
+
+RDEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.25.2:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ virtual/libintl
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( dev-libs/wayland )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}