summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-31 00:52:18 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-31 01:02:37 -0400
commitb9323653f6240231f61bd7e9835264dfb3996fc9 (patch)
treeb01c6dc8d603cc9463d2f6dc4caf6d59ca297abc /media-gfx/libimagequant/libimagequant-2.11.7.ebuild
parentdev-python/pyopenssl-17.5.0: added ~alpha, bug 626836 (diff)
downloadgentoo-b9323653f6240231f61bd7e9835264dfb3996fc9.tar.gz
gentoo-b9323653f6240231f61bd7e9835264dfb3996fc9.tar.bz2
gentoo-b9323653f6240231f61bd7e9835264dfb3996fc9.zip
media-gfx/libimagequant: version bump to 2.11.7
Diffstat (limited to 'media-gfx/libimagequant/libimagequant-2.11.7.ebuild')
-rw-r--r--media-gfx/libimagequant/libimagequant-2.11.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/libimagequant/libimagequant-2.11.7.ebuild b/media-gfx/libimagequant/libimagequant-2.11.7.ebuild
new file mode 100644
index 000000000000..2d2db96f010b
--- /dev/null
+++ b/media-gfx/libimagequant/libimagequant-2.11.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Palette quantization library that powers pngquant and other PNG optimizers"
+HOMEPAGE="https://pngquant.org/lib/"
+SRC_URI="https://github.com/ImageOptim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_sse2 debug openmp static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ tc-export AR CC
+ # Hand rolled configure script, so not all flags are supported.
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ $(use debug && echo --enable-debug) \
+ $(use_enable cpu_flags_x86_sse2 sse) \
+ $(use_with openmp) \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_compile() {
+ emake shared || die "make failed"
+ use static-libs && (emake static || die "make failed")
+}
+
+src_install() {
+ dolib.so libimagequant.so
+ dolib.so libimagequant.so.*
+ use static-libs && dolib.a libimagequant.a
+ doheader libimagequant.h
+ einstalldocs
+}