summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-06-23 16:11:41 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-06-23 16:15:01 +0900
commit1ecc27856c6d64b94e094a64e78f207815d3122a (patch)
tree5045c9311f720e6aa6fbc62b0362082d548a4f64 /media-libs/libsixel/libsixel-1.8.1.ebuild
parentdev-python/python-axolotl-curve25519: Revert "Initial commit." (diff)
downloadgentoo-1ecc27856c6d64b94e094a64e78f207815d3122a.tar.gz
gentoo-1ecc27856c6d64b94e094a64e78f207815d3122a.tar.bz2
gentoo-1ecc27856c6d64b94e094a64e78f207815d3122a.zip
media-libs/libsixel: new upstream release
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/libsixel/libsixel-1.8.1.ebuild')
-rw-r--r--media-libs/libsixel/libsixel-1.8.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libsixel/libsixel-1.8.1.ebuild b/media-libs/libsixel/libsixel-1.8.1.ebuild
new file mode 100644
index 000000000000..12cd9a6cec32
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ --disable-python
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ cd images
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+}