summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-09 09:33:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-09 09:33:45 +0100
commit6c52941361743eef55d07ce6e157895fb72209c9 (patch)
tree8ffca399a8f07846f3a9fd6d39f04320fdfcce35 /media-libs/zimg/zimg-2.0.2.ebuild
parentMerge remote-tracking branch 'remotes/hydrapolic/filebeat' (diff)
downloadgentoo-6c52941361743eef55d07ce6e157895fb72209c9.tar.gz
gentoo-6c52941361743eef55d07ce6e157895fb72209c9.tar.bz2
gentoo-6c52941361743eef55d07ce6e157895fb72209c9.zip
media-libs/zimg: bump to 2.0.2
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/zimg/zimg-2.0.2.ebuild')
-rw-r--r--media-libs/zimg/zimg-2.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-2.0.2.ebuild b/media-libs/zimg/zimg-2.0.2.ebuild
new file mode 100644
index 000000000000..73b4cb907342
--- /dev/null
+++ b/media-libs/zimg/zimg-2.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}