summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-12-24 18:39:37 +0000
committerDavid Seifert <soap@gentoo.org>2017-12-24 23:16:02 +0100
commitfb82335ceee9932c7b19e05dffb354e82c27d331 (patch)
tree1cad9b0e3660f2e91ce1266d681c29c9e27c9e10 /media-libs
parentmedia-libs/opensubdiv: Add CUDA 9 compatibility patch (diff)
downloadgentoo-fb82335ceee9932c7b19e05dffb354e82c27d331.tar.gz
gentoo-fb82335ceee9932c7b19e05dffb354e82c27d331.tar.bz2
gentoo-fb82335ceee9932c7b19e05dffb354e82c27d331.zip
media-libs/opensubdiv: Remove old versions and patches
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opensubdiv/Manifest2
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch34
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.0.ebuild59
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.1.ebuild64
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.0.ebuild6
5 files changed, 3 insertions, 162 deletions
diff --git a/media-libs/opensubdiv/Manifest b/media-libs/opensubdiv/Manifest
index ed3426db6293..91635b621715 100644
--- a/media-libs/opensubdiv/Manifest
+++ b/media-libs/opensubdiv/Manifest
@@ -1,3 +1 @@
-DIST opensubdiv-3.1.0.tar.gz 18014579 BLAKE2B 88f16e81eda8c1626b161f94160d02cda7027dff1ac9c795dfe9694250e707dfa106e564dfa22a18bfd3f5e355337626349b6a162c999c10c4d8c8695d03b925 SHA512 9b59cb4e5b124e222b67a48986251cff91bcdc2aee9f71c4b653ad7bb089e860c5954c251a91c0004fa5c28fc4524a0dcbf51d3ae51ea86ee7665ba05d8ec97f
-DIST opensubdiv-3.1.1.tar.gz 18014871 BLAKE2B 5f3a8a7cfb3f2c4cebb8dab1ea65dde1ac3ef6f42a9603e0fa8c89b2ecdd0f16809510b7b03f6a4c3b0fe522e7b07536a09ab476720d44cc7e4289ba1931beb8 SHA512 700db7e1dde3e916011721a5b42d5e32ea4ae355ab5e3e415541d62efa2059d56d5f30cef853285e95a93f3a3b5fe24a906547a52cce94d47b101ae20021d5b5
DIST opensubdiv-3.3.0.tar.gz 19263469 BLAKE2B f169b5c58877d1dd4ea45cb04d52567803da7c2d11edab072e2b65583109c7c2d52abe07f5bd2b03cba215cdb524a0468900419d8381e95c35eb2f3f4bebe02b SHA512 7c17d847187d46182d08fbee9396fd8793ac04591821084d40da475c9d25560d01575282946e1a30252bba12db9ea06cbf50ff649f91adce72f6127ad6a36418
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch b/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
deleted file mode 100644
index 2ebb638e3838..000000000000
--- a/media-libs/opensubdiv/files/opensubdiv-3.1.0-skip-osd-regression.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -purN a/regression/CMakeLists.txt b/regression/CMakeLists.txt
---- a/regression/CMakeLists.txt 2016-03-25 22:15:29.000000000 +0000
-+++ b/regression/CMakeLists.txt 2016-06-05 14:09:19.202849569 +0100
-@@ -32,30 +32,4 @@ if (NOT NO_REGRESSION)
-
- add_subdirectory(far_perf)
-
-- if(OPENGL_FOUND AND (GLEW_FOUND OR APPLE) AND GLFW_FOUND)
-- add_subdirectory(osd_regression)
-- else()
-- set(MISSING "")
--
-- if (NOT OPENGL_FOUND)
-- list(APPEND MISSING OpenGL)
-- endif()
--
-- if (NOT GLEW_FOUND)
-- list(APPEND MISSING glew)
-- endif()
--
-- if (NOT GLFW_FOUND)
-- list(APPEND MISSING glfw)
-- endif()
--
-- message(WARNING
-- "The following libraries could not be found : ${MISSING}. "
-- "The osd regression test will not be available. "
-- "If you have these libraries installed, please specify their "
-- "path to cmake (through the GLEW_LOCATION and GLFW_LOCATION "
-- "command line arguments or environment variables)."
-- )
-- endif()
--
- endif()
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
deleted file mode 100644
index aa63d90eeda4..000000000000
--- a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils toolchain-funcs versionator
-
-DESCRIPTION="An Open-Source subdivision surface library"
-HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
-
-MY_PV="$(replace_all_version_separators '_')"
-
-SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="cuda doc opencl openmp ptex tbb test"
-
-RDEPEND="media-libs/glew:=
- media-libs/glfw:=
- cuda? ( dev-util/nvidia-cuda-toolkit:* )
- ptex? ( media-libs/ptex )"
-
-DEPEND="${RDEPEND}
- tbb? ( dev-cpp/tbb )
- doc? ( dev-python/docutils app-doc/doxygen )"
-
-KEYWORDS="~amd64 ~x86"
-
-S="${WORKDIR}"/OpenSubdiv-${MY_PV}
-
-PATCHES=( "${FILESDIR}"/${P}-skip-osd-regression.patch )
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- local mycmakeargs=(
- -DNO_MAYA=1
- -DNO_CLEW=1
- -DNO_DOC=$(usex !doc)
- -DNO_TBB=$(usex !tbb)
- -DNO_PTEX=$(usex !ptex)
- -DNO_OMP=$(usex !openmp)
- -DNO_OPENCL=$(usex !opencl)
- -DNO_CUDA=$(usex !cuda)
- -DNO_REGRESSION=$(usex !test)
- -DNO_EXAMPLES=1 # broken
- -DNO_TUTORIALS=1 # broken
- -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- )
-
- cmake-utils_src_configure
-}
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
deleted file mode 100644
index 5c1768b6b37c..000000000000
--- a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils toolchain-funcs versionator
-
-DESCRIPTION="An Open-Source subdivision surface library"
-HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
-
-MY_PV="$(replace_all_version_separators '_')"
-
-SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="cuda doc opencl openmp ptex tbb"
-
-RDEPEND="media-libs/glew:=
- media-libs/glfw:=
- cuda? ( dev-util/nvidia-cuda-toolkit:* )
- ptex? ( media-libs/ptex )"
-
-DEPEND="${RDEPEND}
- tbb? ( dev-cpp/tbb )
- doc? ( dev-python/docutils app-doc/doxygen )"
-
-KEYWORDS="~amd64 ~x86"
-
-S="${WORKDIR}"/OpenSubdiv-${MY_PV}
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -e 's|"${OSD_SONAME}"|${OSD_SONAME}|' \
- -i CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DNO_MAYA=1
- -DNO_CLEW=1
- -DNO_DOC=$(usex !doc)
- -DNO_TBB=$(usex !tbb)
- -DNO_PTEX=$(usex !ptex)
- -DNO_OMP=$(usex !openmp)
- -DNO_OPENCL=$(usex !opencl)
- -DNO_CUDA=$(usex !cuda)
- -DNO_REGRESSION=1 # The don't work with certain settings
- -DNO_EXAMPLES=1 # Broken
- -DNO_TUTORIALS=1 # Broken
- -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- )
-
- cmake-utils_src_configure
-}
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
index a85444ac261c..f34298cd5960 100644
--- a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
+IUSE="cuda doc opencl openmp ptex tbb"
RDEPEND="media-libs/glew:=
media-libs/glfw:=
@@ -54,8 +54,8 @@ src_configure() {
-DNO_OPENCL=$(usex !opencl)
-DNO_CUDA=$(usex !cuda)
-DNO_REGRESSION=1 # They don't work with certain settings
- -DNO_EXAMPLES=$(usex !examples)
- -DNO_TUTORIALS=$(usex !tutorials)
+ -DNO_EXAMPLES=1 # Not needed.
+ -DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
-DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"