summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-11-17 19:50:53 +0200
committerMart Raudsepp <leio@gentoo.org>2019-11-17 19:51:21 +0200
commitfc115d74f4ef6895c0ae06c65ff1cd11b9981592 (patch)
tree1e24d6cfdab0e35249c98b1d8fd9a46ef2475231 /media-libs
parentmedia-libs/cogl: drop unnecessary test deps with tests restricted (diff)
downloadgentoo-fc115d74f4ef6895c0ae06c65ff1cd11b9981592.tar.gz
gentoo-fc115d74f4ef6895c0ae06c65ff1cd11b9981592.tar.bz2
gentoo-fc115d74f4ef6895c0ae06c65ff1cd11b9981592.zip
media-libs/cogl: add missing mesa[egl] dep for USE=kms
If any EGL platform is enabled, it requires the EGL headers. This includes kms-egl-platform, which also sets NEED_EGL in configure.ac. Remove rm -f option usage while here (it makes the `|| die` useless and makes us not notice once this call isn't necessary anymore). Closes: https://bugs.gentoo.org/613728 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/cogl-1.22.4.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-libs/cogl/cogl-1.22.4.ebuild b/media-libs/cogl/cogl-1.22.4.ebuild
index 2191b69cd4aa..12bd445b80ff 100644
--- a/media-libs/cogl/cogl-1.22.4.ebuild
+++ b/media-libs/cogl/cogl-1.22.4.ebuild
@@ -36,7 +36,7 @@ COMMON_DEPEND="
media-libs/gst-plugins-base:1.0 )
introspection? ( >=dev-libs/gobject-introspection-1.34.2:= )
kms? (
- media-libs/mesa[gbm]
+ media-libs/mesa[egl,gbm]
x11-libs/libdrm:= )
pango? ( >=x11-libs/pango-1.20.0[introspection?] )
wayland? (
@@ -114,5 +114,5 @@ src_install() {
gnome2_src_install
# Remove silly examples-data directory
- rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+ rm -rv "${ED}/usr/share/cogl/examples-data/" || die
}