summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 20:26:49 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 20:53:23 -0500
commit2347c6fe886c6b89d93ffac0faf375a613c372b1 (patch)
tree9ac1ed0abe7e86cbfe62a110a23675af21655134 /media-sound/clementine
parentnet-libs/mbedtls: version bump to 2.1.3 (diff)
downloadgentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.gz
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.bz2
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.zip
avoid using ${var^} and ${var,} as they do not work in bash-3.2
Once these upgrade to EAPI=6, they can use these case modification features, so leave a reminder note in there.
Diffstat (limited to 'media-sound/clementine')
-rw-r--r--media-sound/clementine/clementine-1.2.2.ebuild3
-rw-r--r--media-sound/clementine/clementine-1.2.3.ebuild3
-rw-r--r--media-sound/clementine/clementine-9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/media-sound/clementine/clementine-1.2.2.ebuild b/media-sound/clementine/clementine-1.2.2.ebuild
index 9a65d1032530..9eb2fe105b3e 100644
--- a/media-sound/clementine/clementine-1.2.2.ebuild
+++ b/media-sound/clementine/clementine-1.2.2.ebuild
@@ -87,8 +87,9 @@ DOCS="Changelog"
# https://github.com/clementine-player/Clementine/issues/3935
RESTRICT="test"
+# Switch to ^ when we switch to EAPI=6.
[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${P^}"
+S="${WORKDIR}/C${P:1}"
PATCHES=(
"${FILESDIR}"/${P}-fix-build.patch
diff --git a/media-sound/clementine/clementine-1.2.3.ebuild b/media-sound/clementine/clementine-1.2.3.ebuild
index 22d7690b0239..ace65742d613 100644
--- a/media-sound/clementine/clementine-1.2.3.ebuild
+++ b/media-sound/clementine/clementine-1.2.3.ebuild
@@ -90,8 +90,9 @@ DOCS="Changelog"
# https://github.com/clementine-player/Clementine/issues/3935
RESTRICT="test"
+# Switch to ^ when we switch to EAPI=6.
[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${P^}"
+S="${WORKDIR}/C${P:1}"
PATCHES=(
"${FILESDIR}/${PN}-1.2.3-namespaces.patch"
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index e8970fff8f50..e1e83c0137eb 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -88,8 +88,9 @@ DOCS="Changelog"
# https://github.com/clementine-player/Clementine/issues/3935
RESTRICT="test"
+# Switch to ^ when we switch to EAPI=6.
[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${P^}"
+S="${WORKDIR}/C${P:1}"
src_prepare() {
cmake-utils_src_prepare