summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/fapg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/fapg')
-rw-r--r--media-sound/fapg/Manifest2
-rw-r--r--media-sound/fapg/fapg-0.41.ebuild25
-rw-r--r--media-sound/fapg/fapg-0.42.ebuild25
-rw-r--r--media-sound/fapg/metadata.xml8
4 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/fapg/Manifest b/media-sound/fapg/Manifest
new file mode 100644
index 000000000000..ced6a4d393b4
--- /dev/null
+++ b/media-sound/fapg/Manifest
@@ -0,0 +1,2 @@
+DIST fapg-0.41.tar.gz 94315 SHA256 0c09229c1473999f5939770326d8294adfa1847ae3da5f0c7827747284fc54ae SHA512 17efde8cf0760f2eb3136814d9d332352b9c378213104a5540aee381482d3da72fd17e63e96360bcffe1850399124f1c6fcff9471a89881f746453a092d64ceb WHIRLPOOL 5e3cda2ca73490e536eaead81bbb731a6516d63c6bcea58fa05435c4727bb22dce2e713e04f44a9c55ec4d5739a8761fe0df9a934ecf0f236c79894406ac7eb8
+DIST fapg-0.42.tar.gz 94920 SHA256 f324eca6d5fe958be74beb6336d685aa305133c5da26c99b2c0dbc17c68c0076 SHA512 e3bbef35b9c845d80bcd1ee1116e4eb99b98e9d84cff034f2a49bbfcaa7664ab48b9453fb680fe7274fa74e9e0126950fbb15deb793eb95362f74c11151f8731 WHIRLPOOL bdf021c64996599d9a0eb415dd9494f1c0bb5a08c6d78bcdffebdf1076a9f721ca03895dcc088049cfac0f5b1b985245596c6e4cd5e552709b80b32b1940881c
diff --git a/media-sound/fapg/fapg-0.41.ebuild b/media-sound/fapg/fapg-0.41.ebuild
new file mode 100644
index 000000000000..a6fdf7fbe037
--- /dev/null
+++ b/media-sound/fapg/fapg-0.41.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Fast Audio Playlist Generator"
+HOMEPAGE="http://royale.zerezo.com/fapg/"
+SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
+IUSE="xspf"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+RDEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local myconf=""
+ use xspf || myconf="${myconf} --disable-xspf"
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/media-sound/fapg/fapg-0.42.ebuild b/media-sound/fapg/fapg-0.42.ebuild
new file mode 100644
index 000000000000..52761727688a
--- /dev/null
+++ b/media-sound/fapg/fapg-0.42.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Fast Audio Playlist Generator"
+HOMEPAGE="http://royale.zerezo.com/fapg/"
+SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
+IUSE="xspf"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+RDEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local myconf=""
+ use xspf || myconf="${myconf} --disable-xspf"
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/media-sound/fapg/metadata.xml b/media-sound/fapg/metadata.xml
new file mode 100644
index 000000000000..72d447316a74
--- /dev/null
+++ b/media-sound/fapg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+ <use>
+ <flag name="xspf">Enable support for saving XSPF playlists.</flag>
+ </use>
+</pkgmetadata>