summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-22 10:13:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-22 10:13:45 +0200
commit04a50af38f1ab21fbaa3c6fd7542a5d648538cfc (patch)
tree3ff0837aec997ab9da2976075ee528ceb5530965 /media-sound/id3ted
parentmedia-sound/picard: 2.0.3 version bump (diff)
downloadgentoo-04a50af38f1ab21fbaa3c6fd7542a5d648538cfc.tar.gz
gentoo-04a50af38f1ab21fbaa3c6fd7542a5d648538cfc.tar.bz2
gentoo-04a50af38f1ab21fbaa3c6fd7542a5d648538cfc.zip
media-sound/id3ted: 1.0 version bump, EAPI-7
Closes: https://bugs.gentoo.org/534716 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-sound/id3ted')
-rw-r--r--media-sound/id3ted/Manifest1
-rw-r--r--media-sound/id3ted/files/id3ted-1.0-outofbounds.patch22
-rw-r--r--media-sound/id3ted/id3ted-1.0.ebuild27
3 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/id3ted/Manifest b/media-sound/id3ted/Manifest
index 67ff36c93bc1..07b2e766fdc4 100644
--- a/media-sound/id3ted/Manifest
+++ b/media-sound/id3ted/Manifest
@@ -1 +1,2 @@
+DIST id3ted-1.0.tar.gz 32792 BLAKE2B 3df3a5a48302ecac6dbccbf7ddacb3db193e67f8352159d3c31763d03e6bf48c46c2aaf056b0d08649e33c7d4440f72a0dc1869b3d0978cba470bc2b609ff804 SHA512 ba135779ac8bb7e83d77737babc836a2bbf4cd7efd4ffad5aa982ec9f6c57d0479f0bdf017e62d62dddffcadab88ab7b3f07408d173d013b794d20bccd5218ee
DIST id3ted-1.0b3.tar.gz 33023 BLAKE2B 441a5d7a4d486d87b2479184aadb6e067f878877e5e8ef25d01139b2d59e1603d52a31646fcbab2f2c228652cb0d67434bca9ce584c6ba02d4841fa9310c3174 SHA512 6478ee5b6ba652687dd17828a039e8b6fc2b593285c01309c32dfcd7ec4e0e24c10288a195e9b95c47689c844f342498d5151904bd2e596de0e5ec73afa0bd7f
diff --git a/media-sound/id3ted/files/id3ted-1.0-outofbounds.patch b/media-sound/id3ted/files/id3ted-1.0-outofbounds.patch
new file mode 100644
index 000000000000..919ed90e593f
--- /dev/null
+++ b/media-sound/id3ted/files/id3ted-1.0-outofbounds.patch
@@ -0,0 +1,22 @@
+From a044c5659bf29df8152feabba63a83dc6feb7a99 Mon Sep 17 00:00:00 2001
+From: denmord <denis.khabenkov@gmail.com>
+Date: Fri, 20 Jan 2017 20:36:31 +0300
+Subject: [PATCH] Fixed writing outside the bounds of the array
+
+---
+ fileio.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fileio.cpp b/fileio.cpp
+index 35d992f..edfe2de 100644
+--- a/fileio.cpp
++++ b/fileio.cpp
+@@ -154,7 +154,7 @@ FileIO::Status FileIO::resetTimes(const char *filename, const FileTimes &times)
+ }
+
+ FileIO::Status FileIO::createDir(const char *path) {
+- char *directory = new char[strlen(path + 1)];
++ char *directory = new char[strlen(path) + 1];
+ char *curr = directory;
+ struct stat stats;
+ Status ret = Success;
diff --git a/media-sound/id3ted/id3ted-1.0.ebuild b/media-sound/id3ted/id3ted-1.0.ebuild
new file mode 100644
index 000000000000..8647777f37f4
--- /dev/null
+++ b/media-sound/id3ted/id3ted-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Command-line ID3 Tag Editor"
+HOMEPAGE="https://muennich.github.com/id3ted/"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/taglib
+ sys-apps/file"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-outofbounds.patch" )
+
+pkg_setup() {
+ export PREFIX="/usr"
+ tc-export CXX
+}