summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-10 18:39:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-10 18:39:11 +0200
commitafdee627b5077b5697b7e9fd001c56a1c84e4c8f (patch)
treeffe419a3950d16fe1214aa350cb21933a0243d4f /media-sound/pamix
parentdev-perl/Test-Warn: ALLARCHES stable wrt bug #585502 (diff)
downloadgentoo-afdee627b5077b5697b7e9fd001c56a1c84e4c8f.tar.gz
gentoo-afdee627b5077b5697b7e9fd001c56a1c84e4c8f.tar.bz2
gentoo-afdee627b5077b5697b7e9fd001c56a1c84e4c8f.zip
media-sound/pamix: Initial commit (bug #590728).
Thanks to Joshua Jensch for the bug report and the ebuild work. Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound/pamix')
-rw-r--r--media-sound/pamix/Manifest1
-rw-r--r--media-sound/pamix/metadata.xml11
-rw-r--r--media-sound/pamix/pamix-1.1.ebuild30
-rw-r--r--media-sound/pamix/pamix-9999.ebuild30
4 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/pamix/Manifest b/media-sound/pamix/Manifest
new file mode 100644
index 000000000000..e696d39d74b3
--- /dev/null
+++ b/media-sound/pamix/Manifest
@@ -0,0 +1 @@
+DIST pamix-1.1.tar.gz 7955 SHA256 81e88b5c305b2864ea5c6adda79a9a2fe18c7ed7721354e865862e779acb6f5f SHA512 cdec746bfbb1887d558762a0247370616f480b4695a7802f4ac47c7d9f545efe77af228b1992dd61e2bed09118ca095546bde206be4b8dfea1839b91c768cdbc WHIRLPOOL c1113e4783637c1ec5f77be735d4a96ffc3060449571ad3f32d06e9d369c7dba6140863ab5b2f0a19f78b7a591614c32980e1e87c8ec950fe3e589514e5759a2
diff --git a/media-sound/pamix/metadata.xml b/media-sound/pamix/metadata.xml
new file mode 100644
index 000000000000..88f381f7a09d
--- /dev/null
+++ b/media-sound/pamix/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">patroclos/PAmix</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/pamix/pamix-1.1.ebuild b/media-sound/pamix/pamix-1.1.ebuild
new file mode 100644
index 000000000000..986dad71c324
--- /dev/null
+++ b/media-sound/pamix/pamix-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+[[ "${PV}" == 9999 ]] && inherit git-r3
+
+DESCRIPTION="A PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/patroclos/PAmix.git"
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+RDEPEND="media-sound/pulseaudio
+ sys-libs/ncurses:0=[unicode]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ [[ "${PV}" == 9999 ]] && git-r3_src_unpack
+ default
+}
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
new file mode 100644
index 000000000000..986dad71c324
--- /dev/null
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+[[ "${PV}" == 9999 ]] && inherit git-r3
+
+DESCRIPTION="A PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/patroclos/PAmix.git"
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+RDEPEND="media-sound/pulseaudio
+ sys-libs/ncurses:0=[unicode]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ [[ "${PV}" == 9999 ]] && git-r3_src_unpack
+ default
+}