summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pamix/pamix-1.1.ebuild')
-rw-r--r--media-sound/pamix/pamix-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/pamix/pamix-1.1.ebuild b/media-sound/pamix/pamix-1.1.ebuild
new file mode 100644
index 000000000000..986dad71c324
--- /dev/null
+++ b/media-sound/pamix/pamix-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+[[ "${PV}" == 9999 ]] && inherit git-r3
+
+DESCRIPTION="A PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/patroclos/PAmix.git"
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+RDEPEND="media-sound/pulseaudio
+ sys-libs/ncurses:0=[unicode]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ [[ "${PV}" == 9999 ]] && git-r3_src_unpack
+ default
+}