summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-21 02:26:33 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-21 02:26:55 +0200
commit5484b21ca35d648b6c92b4f6cbf5f460268ae3c3 (patch)
treea8b71de74f812b795fd1697cff1b9f169a09739b /media-sound/pulseaudio
parentapp-text/lowdown: add missing virtual/libcrypt subslot operator (diff)
downloadgentoo-5484b21ca35d648b6c92b4f6cbf5f460268ae3c3.tar.gz
gentoo-5484b21ca35d648b6c92b4f6cbf5f460268ae3c3.tar.bz2
gentoo-5484b21ca35d648b6c92b4f6cbf5f460268ae3c3.zip
media-sound/pulseaudio: fix building with USE=-glib
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch36
-rw-r--r--media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild2
2 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
new file mode 100644
index 000000000000..dfce24881566
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
@@ -0,0 +1,36 @@
+From fe25df45d5742f20a225e9d9cd790156a7f05943 Mon Sep 17 00:00:00 2001
+From: "Igor V. Kovalenko" <igor.v.kovalenko@gmail.com>
+Date: Mon, 21 Jun 2021 02:32:41 +0300
+Subject: [PATCH] build-sys: meson: require GIO dependency for RTP-GStreamer
+
+---
+ meson.build | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index fdd8bf655..61660b981 100644
+--- a/meson.build
++++ b/meson.build
+@@ -614,8 +614,9 @@ if dbus_dep.found()
+ cdata.set('HAVE_DBUS', 1)
+ endif
+
+-gio_dep = dependency('gio-2.0', version : '>= 2.26.0', required : get_option('gsettings'))
+-if gio_dep.found()
++gio_dep = dependency('gio-2.0', version : '>= 2.26.0')
++if get_option('gsettings').enabled()
++ assert(gio_dep.found(), 'GSettings support needs glib I/O library (GIO)')
+ cdata.set('HAVE_GSETTINGS', 1)
+ endif
+
+@@ -760,6 +761,7 @@ gstrtp_dep = dependency('gstreamer-rtp-1.0', required : get_option('gstreamer'))
+
+ have_gstreamer = false
+ if gst_dep.found() and gstapp_dep.found() and gstrtp_dep.found()
++ assert(gio_dep.found(), 'GStreamer-based RTP needs glib I/O library (GIO)')
+ have_gstreamer = true
+ endif
+
+--
+GitLab
+
diff --git a/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild b/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild
index aa307be10687..203ebb43b879 100644
--- a/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-14.99.2_pre.ebuild
@@ -164,6 +164,8 @@ DOCS=( NEWS README )
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${MY_P}-require-GIO-for-RTP-GStreamer.patch )
+
src_prepare() {
default