summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-04 20:26:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-07 14:12:14 +0200
commit1bd6ffd5e108e0e177e6a4081dc5d5ef9a92978d (patch)
tree2ae5e58de008913a67d4a09ddcb562ed68d596c5 /media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild
parentapp-doc/kicad-doc: remove old (diff)
downloadgentoo-1bd6ffd5e108e0e177e6a4081dc5d5ef9a92978d.tar.gz
gentoo-1bd6ffd5e108e0e177e6a4081dc5d5ef9a92978d.tar.bz2
gentoo-1bd6ffd5e108e0e177e6a4081dc5d5ef9a92978d.zip
media-sound/tempest_for_eliza: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/665236 Closes: https://github.com/gentoo/gentoo/pull/9778
Diffstat (limited to 'media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild')
-rw-r--r--media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..c1f630a8951e
--- /dev/null
+++ b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Listen to music on the radio generated by images on your screen"
+HOMEPAGE="http://www.erikyyy.de/tempest/"
+SRC_URI="http://www.erikyyy.de/tempest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CXX
+ econf \
+ --enable-debug \
+ --enable-nowarnerror
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ rm songs/Makefile* || die
+ insinto /usr/share/${PN}
+ doins songs/*
+}