summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild')
-rw-r--r--media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..c1f630a8951e
--- /dev/null
+++ b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Listen to music on the radio generated by images on your screen"
+HOMEPAGE="http://www.erikyyy.de/tempest/"
+SRC_URI="http://www.erikyyy.de/tempest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CXX
+ econf \
+ --enable-debug \
+ --enable-nowarnerror
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ rm songs/Makefile* || die
+ insinto /usr/share/${PN}
+ doins songs/*
+}