summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-26 13:35:31 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-26 13:51:01 +0200
commit719194d41a72283e27a1a85697c96e571d793f4d (patch)
tree1f808870d0e816b16ad1bb1f08d1bcc95532c71d /media-video
parentmedia-video/libav: Remove support for non-existent deps (diff)
downloadgentoo-719194d41a72283e27a1a85697c96e571d793f4d.tar.gz
gentoo-719194d41a72283e27a1a85697c96e571d793f4d.tar.bz2
gentoo-719194d41a72283e27a1a85697c96e571d793f4d.zip
media-video/parole: Remove support for non-existent deps
Diffstat (limited to 'media-video')
-rw-r--r--media-video/parole/parole-1.0.0.ebuild10
-rw-r--r--media-video/parole/parole-1.0.1.ebuild10
2 files changed, 6 insertions, 14 deletions
diff --git a/media-video/parole/parole-1.0.0.ebuild b/media-video/parole/parole-1.0.0.ebuild
index 19fa3b98c738..09bfa0b3870f 100644
--- a/media-video/parole/parole-1.0.0.ebuild
+++ b/media-video/parole/parole-1.0.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips x86"
-IUSE="clutter libnotify taglib"
+IUSE="libnotify taglib"
COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.32:2=
@@ -24,11 +24,6 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
>=xfce-base/libxfce4util-4.11:0=
>=xfce-base/xfconf-4.10:0=
- clutter? (
- >=media-libs/clutter-1.16.4:1.0=
- >=media-libs/clutter-gtk-1.4.4:1.0=
- <x11-libs/gtk+-3.22:3
- )
libnotify? ( >=x11-libs/libnotify-0.7:0= )
taglib? ( >=media-libs/taglib-1.6:0= )"
RDEPEND="${COMMON_DEPEND}
@@ -43,7 +38,8 @@ DOCS=( AUTHORS ChangeLog README THANKS TODO )
src_configure() {
local myconf=(
- $(use_enable clutter)
+ # clutter backend does not work with new GTK+3 versions
+ --disable-clutter
$(use_enable taglib)
$(use_enable libnotify notify-plugin)
)
diff --git a/media-video/parole/parole-1.0.1.ebuild b/media-video/parole/parole-1.0.1.ebuild
index 6bc14f9e8690..e25d25434825 100644
--- a/media-video/parole/parole-1.0.1.ebuild
+++ b/media-video/parole/parole-1.0.1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86"
-IUSE="clutter libnotify taglib"
+IUSE="libnotify taglib"
COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.32:2=
@@ -24,11 +24,6 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
>=xfce-base/libxfce4util-4.11:0=
>=xfce-base/xfconf-4.10:0=
- clutter? (
- >=media-libs/clutter-1.16.4:1.0=
- >=media-libs/clutter-gtk-1.4.4:1.0=
- <x11-libs/gtk+-3.22:3
- )
libnotify? ( >=x11-libs/libnotify-0.7:0= )
taglib? ( >=media-libs/taglib-1.6:0= )"
RDEPEND="${COMMON_DEPEND}
@@ -43,7 +38,8 @@ DOCS=( AUTHORS ChangeLog README THANKS TODO )
src_configure() {
local myconf=(
- $(use_enable clutter)
+ # clutter backend does not work with new GTK+3 versions
+ --disable-clutter
$(use_enable taglib)
$(use_enable libnotify notify-plugin)
)