summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-20 15:04:08 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-20 15:06:18 +0200
commit09820b316c5ffe7ca4ef801fd1481fe967bef5b3 (patch)
tree99e6821944460a1888d6e87d2bf0ba8bf02d692c /net-analyzer/flowgrind
parentapp-mobilephone/wammu: Remove last-rited pkg (diff)
downloadgentoo-09820b316c5ffe7ca4ef801fd1481fe967bef5b3.tar.gz
gentoo-09820b316c5ffe7ca4ef801fd1481fe967bef5b3.tar.bz2
gentoo-09820b316c5ffe7ca4ef801fd1481fe967bef5b3.zip
net-analyzer/flowgrind: Fix building with CFLAGS=-fno-common
https://github.com/flowgrind/flowgrind/pull/227 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://bugs.gentoo.org/738186 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/flowgrind')
-rw-r--r--net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch36
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild49
2 files changed, 85 insertions, 0 deletions
diff --git a/net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch b/net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch
new file mode 100644
index 000000000000..60835b858816
--- /dev/null
+++ b/net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch
@@ -0,0 +1,36 @@
+--- a/src/daemon.c
++++ b/src/daemon.c
+@@ -86,6 +86,10 @@
+
+ int daemon_pipe[2];
+
++pthread_t daemon_thread;
++char *dump_prefix;
++char *dump_dir;
++
+ pthread_mutex_t mutex;
+ struct request *requests = 0, *requests_last = 0;
+
+--- a/src/daemon.h
++++ b/src/daemon.h
+@@ -252,7 +252,7 @@
+ int num_flows;
+ };
+
+-pthread_t daemon_thread;
++extern pthread_t daemon_thread;
+
+ /* Through this pipe we wakeup the thread from select */
+ extern int daemon_pipe[2];
+@@ -268,9 +268,8 @@
+ * large a reply can get */
+ struct report* get_reports(int *has_more);
+
+-/* FIXME: shouldn't be global? */
+-char *dump_prefix;
+-char *dump_dir;
++extern char *dump_prefix;
++extern char *dump_dir;
+
+ void *daemon_main(void* ptr);
+ void add_report(struct report* report);
diff --git a/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild b/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..2c2e1839abfa
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gsl pcap"
+
+RDEPEND="
+ dev-libs/xmlrpc-c[abyss,curl]
+ sys-apps/util-linux
+ gsl? ( sci-libs/gsl )
+ pcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-fno-common.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc doxygen) \
+ $(use_with gsl) \
+ $(use_with pcap)
+}
+
+src_compile() {
+ default
+
+ use doc && emake html
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html
+}