summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-05-02 20:37:26 +0200
committerJeroen Roovers <jer@gentoo.org>2018-05-02 20:37:41 +0200
commit433e897529f5a41682189da5dba5a9f853c39456 (patch)
tree79d1913fa135fb509525c3ab4c417cd561afe91b /net-analyzer/wireshark/files
parentsys-kernel/gentoo-sources: Linux patch 4.16.7 (diff)
downloadgentoo-433e897529f5a41682189da5dba5a9f853c39456.tar.gz
gentoo-433e897529f5a41682189da5dba5a9f853c39456.tar.bz2
gentoo-433e897529f5a41682189da5dba5a9f853c39456.zip
net-analyzer/wireshark: Switch to cmake (bug #545688).
Package-Manager: Portage-2.3.32, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/wireshark/files')
-rw-r--r--net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch b/net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch
new file mode 100644
index 000000000000..e28465e814a5
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch
@@ -0,0 +1,26 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2841,6 +2841,7 @@
+ if(HAVE_LIBPCAP)
+ set(androiddump_LIBS
+ ui
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ )
+@@ -2851,6 +2852,7 @@
+ set(androiddump_LIBS
+ ui
+ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+@@ -2862,7 +2864,6 @@
+ )
+
+ add_executable(androiddump WIN32 ${androiddump_FILES})
+- # XXX Shouldn't we add wsutil to androiddump_LIBS instead?
+ set_extcap_executable_properties(androiddump)
+ target_link_libraries(androiddump ${androiddump_LIBS})
+ install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})