summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-19 20:29:15 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-19 20:29:15 +0200
commit4fe5206a7135627bcb2a398f007b035b007c6317 (patch)
tree2ddfd46b02b832cde6225b11361aaba946406f63 /net-analyzer
parentgames-mud/gnome-mud-0.11.2-r2: amd64 stable (diff)
downloadgentoo-4fe5206a7135627bcb2a398f007b035b007c6317.tar.gz
gentoo-4fe5206a7135627bcb2a398f007b035b007c6317.tar.bz2
gentoo-4fe5206a7135627bcb2a398f007b035b007c6317.zip
net-analyzer/tcpflow: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpflow/Manifest1
-rw-r--r--net-analyzer/tcpflow/tcpflow-1.4.5_p4-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/tcpflow/Manifest b/net-analyzer/tcpflow/Manifest
index 5ed4cea1e275..d8b44b27b57b 100644
--- a/net-analyzer/tcpflow/Manifest
+++ b/net-analyzer/tcpflow/Manifest
@@ -1,2 +1,3 @@
DIST tcpflow_1.4.5+repack1-1.debian.tar.xz 11144 SHA256 b917e994ac1cd64cb63f719700b0a9862359779286cab89c9c29f73e64ec2d5b SHA512 ed2c491595a3d5382ca79fe945467639af3d99658d002353f90e07aa6b1a955e57ab0fbbc3fadf964e9d6d3dba4fd327a02c1b07d6a239efdf90b365928b2a1e WHIRLPOOL 0854405a429bd2f7276b18acc204e5ac5cfde1bbd4a8f5308e6bf667355eb1ea8a98c52b30a5a24aacb4f8f7b8469e75c2c49fc5f187aa87b869fad9c91d025c
+DIST tcpflow_1.4.5+repack1-4.debian.tar.xz 12228 SHA256 f7207ea03e9aa1c96ec322835aed486a7fde2244d26ce4d9b23cb75d613a0e07 SHA512 27d8a7a735b06c35cc2985cb26a129a490fc2236eedeede21977afe4c3096a6fde3ea18de1aaa3a1c6a56bc36d332b1e8bd4c7be933d5b031509a69cae189b18 WHIRLPOOL 35817c9ca6cfec60d91d4809ae1661f26011c0f4fe020c15a168e82651a6dfa9c63a87188428675dbc7330ab43b0fcdc443b7d7ec954007fbbc8f4f5d9b7df3d
DIST tcpflow_1.4.5+repack1.orig.tar.gz 725962 SHA256 1d9b4ce2dd85adc1c608f34ada576b7f5b6d51c686ae6b870c3c277049a24af0 SHA512 fed8589957e3c790b5b6837b9b578d5dcbde316122ed6b3d4f908d1d73f23c6ed8a11720ee0510e878eaa7a6c559a2f35e7df2c77e3cb1f2810040adf7ac2b85 WHIRLPOOL 8743e20cea0fbee37c9ee050e8bbe02871e8a32dba2bbed922b912de457aa4eaf5cd21e8828a08eb3eafbf8d3897541230fc37bc4a15f7126e6b8adfb9fea860
diff --git a/net-analyzer/tcpflow/tcpflow-1.4.5_p4-r1.ebuild b/net-analyzer/tcpflow/tcpflow-1.4.5_p4-r1.ebuild
new file mode 100644
index 000000000000..d98e0670e726
--- /dev/null
+++ b/net-analyzer/tcpflow/tcpflow-1.4.5_p4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A tool for monitoring, capturing and storing TCP connections flows"
+HOMEPAGE="https://github.com/simsong/tcpflow http://packages.qa.debian.org/t/tcpflow.html"
+SRC_URI="
+ mirror://debian/pool/main/t/${PN}/${PN}_${PV/_p*}+repack1.orig.tar.gz
+ mirror://debian/pool/main/t/${PN}/${PN}_${PV/_p*}+repack1-${PV/*_p}.debian.tar.xz
+"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+SLOT="0"
+IUSE="cairo test"
+
+RDEPEND="
+ app-forensics/afflib
+ dev-libs/boost
+ dev-libs/openssl:=
+ net-libs/http-parser:=
+ net-libs/libpcap
+ sys-libs/zlib
+ cairo? (
+ x11-libs/cairo
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( sys-apps/coreutils )
+"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ eapply "${WORKDIR}"/debian/patches/*.patch
+
+ mv -f README{.md,} || die
+
+ sed -i -e 's:`md5 -q \(.*\)`:`md5sum \1 | cut -f1 -d" "`:' tests/*.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex cairo --enable-cairo=true --enable-cairo=false) \
+ --without-o3
+}