summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-11-30 18:20:19 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-11-30 18:27:07 -0500
commit51148f5256d4c1d10138f967a884a6f7aa58fdca (patch)
tree89add66feb3ec370099dcb366ba11cbc2ca8ff83 /net-analyzer
parentapp-arch/xz-utils: add sourceforge upstream metadata (diff)
downloadgentoo-51148f5256d4c1d10138f967a884a6f7aa58fdca.tar.gz
gentoo-51148f5256d4c1d10138f967a884a6f7aa58fdca.tar.bz2
gentoo-51148f5256d4c1d10138f967a884a6f7aa58fdca.zip
net-analyzer/nagios-plugins: use ping/ping6 from $PATH in v2.4.2.
We pass explicit ping/ping6 commands to the nagios-plugins ./configure script to prevent it from running those commands during the build. However, instead of grabbing their paths from $PATH, we have (until now) hard-coded them to /bin/ping and /bin/ping6. This has now bitten us with net-misc/iputils-20221126. This commit uses $(command -v ...) to get the right absolute paths. Thanks to Daniel Pouzzner for reporting the problem and suggesting the fix. Closes: https://bugs.gentoo.org/883765 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.4.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.4.2.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.4.2.ebuild
index 7b20af18afa6..8fe32f3ad69a 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-2.4.2.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-2.4.2.ebuild
@@ -83,11 +83,12 @@ src_configure() {
fi
# The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered. Bug #468296.
- myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
+ # down or ICMP traffic is filtered (bug #468296). But also the path
+ # likes to move around on us (bug #883765).
+ myconf+=( --with-ping-command="$(command -v ping) -n -U -w %d -c %d %s" )
if use ipv6; then
- myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
+ myconf+=( --with-ping6-command="$(command -v ping6) -n -U -w %d -c %d %s" )
fi
econf \