summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-24 20:55:29 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-24 20:55:29 +0200
commit53a6778a5b26e497c14d1b0a1651b206e892b559 (patch)
tree825e877d01eba69e7809006b1764ab3d6194d1f0 /net-analyzer
parentdev-util/promu: Remove old (diff)
downloadgentoo-53a6778a5b26e497c14d1b0a1651b206e892b559.tar.gz
gentoo-53a6778a5b26e497c14d1b0a1651b206e892b559.tar.bz2
gentoo-53a6778a5b26e497c14d1b0a1651b206e892b559.zip
net-analyzer/prometheus: Version bump to 2.0.0_beta5
Package-Manager: Portage-2.3.10, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.0.0_beta5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index c18e8a28fae2..fb4f8722e752 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1,2 +1,3 @@
DIST prometheus-1.7.1.tar.gz 5122747 SHA256 209832310f5bef99faef3beaaa95263612a4d0126ca512c4a4c23a8543d3ccf5 SHA512 98a42e95978477530082d7549c29f17b133043d7c233ba3c90b183f06a3f24ee578f8fed75cba476d3c93a22abcccfdbccc94488beb8450a02f260d24165ba26 WHIRLPOOL 8ab473430752336e09b4a0c38fd1117abe21196478d7f2f7e813c27f07c950cc3525d9e9ba32309711c73a1032f3cff27ddc1582d0c4b6c66fe82d5b58675550
DIST prometheus-2.0.0_beta4.tar.gz 5534359 SHA256 81196ea9d678c339ba592f29c0f0bdf6bd050862065c5b45351588dc47efbbce SHA512 2d2727e34cb6d71ba4ac431d3300a47482522c115f602358ce77c3ababb2defeec863d10d8cffc0325be0a9dde16e7c3beeed9a0f3c7b6b3b0db86e77e715b6c WHIRLPOOL 52abc94fa55d52e49d3da6a10e6504e07e5cafd635f7c337b941939ee5ff4a112dc7dfee0bfa96ae99086da9f2b14fb79eedb36158f4c0a746a77d3b158d386d
+DIST prometheus-2.0.0_beta5.tar.gz 5533740 SHA256 451d4c76fe583de1df3d6164aaec1ff2105ee449706acd1843f1a2119440914e SHA512 d84fddd5eb2f03b1edf95cd4fa83312f6e617be863ea77a05864345aa1685ad227e82002d9beb3efc1c18ea6a2539dbfdbcc20aa9d2c0ba510ac7293702b4bd9 WHIRLPOOL 7facfaba5727ffa519e633f49f1ef6b59b67a11ab978eacd6533c487df68a96d46fde6ed231f48c67684a214bbbc8a88e37901a5d835d7ffacb27e702d98d348
diff --git a/net-analyzer/prometheus/prometheus-2.0.0_beta5.ebuild b/net-analyzer/prometheus/prometheus-2.0.0_beta5.ebuild
new file mode 100644
index 000000000000..8fe0ba81b574
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.0.0_beta5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_beta/-beta.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="64c7932"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_beta4'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}