summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-05 15:01:32 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-05 15:01:32 +0200
commit5db0ef9c70953f74cd59053fe385a3bd5cb8b83b (patch)
treed7d829426f85c8b5556173daef5a6f2da6001696 /net-analyzer
parentdev-qt/qtwebengine: allow NINJAFLAGS to be overridden (diff)
downloadgentoo-5db0ef9c70953f74cd59053fe385a3bd5cb8b83b.tar.gz
gentoo-5db0ef9c70953f74cd59053fe385a3bd5cb8b83b.tar.bz2
gentoo-5db0ef9c70953f74cd59053fe385a3bd5cb8b83b.zip
net-analyzer/prometheus: Version bump to 1.6.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-1.6.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index 8095ccebd636..6e5f34b325f0 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1 +1,2 @@
DIST prometheus-1.6.2.tar.gz 5160925 SHA256 026fd958ae3792938613675f455131e954552471d15df971251b46e64ca50b35 SHA512 ae34f64d6ab2c01cb872b882e78e713b65a9ac2d42a8f6d8eaf448874d01db7b60cdc0a652a19812f9fb17d17e1454b09fc762bf624fef67d7bad56634245948 WHIRLPOOL d9e8817034d7347a57196b30a0c8293b0d44158b1a60b0d7ad6361899911a7a39ff2f4dc9fbe55d0203907dacbab4b19ba42fe954b840bd78d683c89db00700f
+DIST prometheus-1.6.3.tar.gz 5160067 SHA256 1c2d01f3a44b53be3b672cbdb1843fbe8fc135020bbfb6c71b0a10b141a474e6 SHA512 e7cad489120a69356ffa70597d725de9586cd64f0eb64ef3fb009ec491687d5e2d858223594d3a4e6d564196c9ea5a0eac762c0f27c9f32d50bf97d2ef79c32b WHIRLPOOL 9cb600621aad1c97f1ced7259fe442b38b24a88cf4b8df7d19a22f6d2f6840464f8db01caf1129800bd7c7ccb232d875aa7b92a194f2abea1f126854306f0817
diff --git a/net-analyzer/prometheus/prometheus-1.6.3.ebuild b/net-analyzer/prometheus/prometheus-1.6.3.ebuild
new file mode 100644
index 000000000000..09bcc54c842a
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-1.6.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+EGIT_COMMIT="v${PV}"
+PROMETHEUS_COMMIT="c580b60"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.8
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}