summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-01 23:20:45 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-01 23:23:33 +0200
commit6f23817391c82f654a56d4fb9ce755076cc89734 (patch)
tree883929adb83aa6e7b26e6442dc014a5584e59b1e /net-analyzer
parentnet-misc/youtube-dl: Stable (diff)
downloadgentoo-6f23817391c82f654a56d4fb9ce755076cc89734.tar.gz
gentoo-6f23817391c82f654a56d4fb9ce755076cc89734.tar.bz2
gentoo-6f23817391c82f654a56d4fb9ce755076cc89734.zip
net-analyzer/scapy: Version 2.4.3_rc2
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/scapy/Manifest1
-rw-r--r--net-analyzer/scapy/scapy-2.4.3_rc2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index 7214248b56f3..ab629fbb523e 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -2,3 +2,4 @@ DIST scapy-2.3.2.tar.gz 1166056 BLAKE2B bce5f37bd833dc457089cdfebd2dc019c4f7bed6
DIST scapy-2.4.0.tar.gz 3182131 BLAKE2B af591b103c90736a5e62801f4c0ebd495e2e71c79ee81f04fdd194739b460c9940b8fcf0c6e279701095979144eff25ca4734926c0251721b37dc63fe8dd9e89 SHA512 0fe80150cd83db7735c9d0b70ec832a4e68eb5160ad8559e9b1bd79c52a9950ef7c9555ea2a1ee1dc8df1f055a885c52552c29e304faf40250ce9c502a5f870a
DIST scapy-2.4.2.tar.gz 3330071 BLAKE2B a40074594cd561b33d04364fba743fa5fe741b06b2ad8f8f9ebe9dfb0b9a3bc4f641cd16d99a4ba070fc0763d7cfeb8d3ecd056f162d509070cdd57d55d6ad9c SHA512 980f708a849ae26edca3eb6618a41668818c5883bca699f347f47a8964b3ee44a6ceefe4a12cb7d5fe6c13f5cbe2b7547938e53139f4ec9e6ef384e30c9bb6db
DIST scapy-2.4.3_rc1.tar.gz 2455703 BLAKE2B 7db2af39afad694b49296d0e02a7e649c31023fbb12d66faccb777e297240b84e39558dd0ba56dab159e8412cec93d868ec02542afa385e2ec49d1a80b8788d4 SHA512 29996996521d5802b435c27dee5ad91fdd3e974dc86a3ba1377c67eb5c81a639fdfa18790ca2275df54685a963f7c69bde10b01887ba54315ddef6d2c002f8d8
+DIST scapy-2.4.3_rc2.tar.gz 2785755 BLAKE2B 75c89f22beafbc9350d0f42fd186a4860d0c3146d543c66a6a8561d9c644ce92496c678740abfdfaf5811e3da01de211c76b590920c0860fc04c61e8f19bf0eb SHA512 09e45742a87be31f9230f6948f4d746f16fcd37aaae257d456deefa4ed7d9adcd93f647910210d0fc7d8d1db05a6d62a3937550d560d6099672a3360dfd0c88d
diff --git a/net-analyzer/scapy/scapy-2.4.3_rc2.ebuild b/net-analyzer/scapy/scapy-2.4.3_rc2.ebuild
new file mode 100644
index 000000000000..25877178edf3
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.3_rc2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}