summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-11-22 10:13:28 +0000
committerMarek Szuba <marecki@gentoo.org>2018-11-22 10:23:04 +0000
commit740faf22dd238fa89bcdfbb8978a12bd9f25b859 (patch)
tree229fd939e6a430c2dc6a312810adb7b2bade5a36 /net-analyzer
parentnet-analyzer/nessus-bin: add self as primary maintainer (diff)
downloadgentoo-740faf22dd238fa89bcdfbb8978a12bd9f25b859.tar.gz
gentoo-740faf22dd238fa89bcdfbb8978a12bd9f25b859.tar.bz2
gentoo-740faf22dd238fa89bcdfbb8978a12bd9f25b859.zip
net-analyzer/nessus-bin: bump to 8.0.1 and EAPI 7
Also, confirmed this version automatically creates the directory for its user data so it is possible to trivially avoid Bug #645740. Closes: https://bugs.gentoo.org/635476 Closes: https://bugs.gentoo.org/645740 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nessus-bin/Manifest1
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-8.0.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-analyzer/nessus-bin/Manifest b/net-analyzer/nessus-bin/Manifest
index 3bc6b2214d1b..011ab7c4dacf 100644
--- a/net-analyzer/nessus-bin/Manifest
+++ b/net-analyzer/nessus-bin/Manifest
@@ -1 +1,2 @@
DIST Nessus-6.10.5-es7.x86_64.rpm 41596796 BLAKE2B 2d9078eb3a53bc9fe63a649f6829ac757424bdecd007bdcaefcda661951a18918ce4f2823fe3ae88ded68453e82a06ccd2d225db26713c5b72bdd09f9e665b1d SHA512 a407aa010d3d59d5c4d717159851a6b81ef9e1f1b4327c8382abe1b866c4969cf6e32251077270eae719b66af9ce29641c40ca6093df30f88ce9be81ba168f75
+DIST Nessus-8.0.1-es7.x86_64.rpm 62028348 BLAKE2B 07e174d8d3c68773e55cacf57ca836163288db0c4458a8e987279ef9099a82c662aaf00699e5938afe51d549a1114144a0fef246151d4b2c088367bc900236aa SHA512 4351c40e0133f1ca56d0366814b9daba1ee4e12aa496fcc23971f26e9313fdab9c195b43c0848488acdea178a95d383bdf46ecf0355a2214713ce23458156ab9
diff --git a/net-analyzer/nessus-bin/nessus-bin-8.0.1.ebuild b/net-analyzer/nessus-bin/nessus-bin-8.0.1.ebuild
new file mode 100644
index 000000000000..ed738ccba2e2
--- /dev/null
+++ b/net-analyzer/nessus-bin/nessus-bin-8.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm pax-utils systemd
+
+MY_P="Nessus-${PV}-es7"
+
+DESCRIPTION="A remote security scanner for Linux"
+HOMEPAGE="https://www.tenable.com/"
+SRC_URI="${MY_P}.x86_64.rpm"
+
+LICENSE="GPL-2 Nessus-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+QA_PREBUILT="opt/nessus/bin/nasl
+ opt/nessus/bin/ndbg
+ opt/nessus/bin/nessus-mkrand
+ opt/nessus/lib/nessus/libjemalloc.so.${PV}
+ opt/nessus/lib/nessus/libnessus-glibc-fix.so
+ opt/nessus/sbin/nessus-service
+ opt/nessus/sbin/nessuscli
+ opt/nessus/sbin/nessusd"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from ${HOMEPAGE}/downloads/nessus"
+ einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+src_install() {
+ # Using doins -r would strip executable bits from all binaries
+ cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
+
+ pax-mark m "${D}"/opt/nessus/sbin/nessusd
+
+ # Make sure these originally empty directories do not vanish,
+ # Nessus will not run properly without them
+ keepdir /opt/nessus/com/nessus/CA
+ keepdir /opt/nessus/etc/nessus
+ keepdir /opt/nessus/var/nessus/logs
+ keepdir /opt/nessus/var/nessus/tmp
+
+ newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
+ systemd_newunit usr/lib/systemd/system/nessusd.service nessusd-bin.service
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To get started launch the nessusd-bin service, then point your Web browser to"
+ elog " https://<yourhost>:8834/"
+ else
+ elog "You may want to restart the nessusd-bin service to use"
+ elog "the new version of Nessus."
+ fi
+}