summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-18 18:35:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-18 18:35:31 +0100
commit76d52db8378f0c3ed938642f3ef957ca0faafe8d (patch)
treedd261807232b75422039f839df8d79e344956483 /net-analyzer
parentnet-analyzer/ippl: Remove old (diff)
downloadgentoo-76d52db8378f0c3ed938642f3ef957ca0faafe8d.tar.gz
gentoo-76d52db8378f0c3ed938642f3ef957ca0faafe8d.tar.bz2
gentoo-76d52db8378f0c3ed938642f3ef957ca0faafe8d.zip
net-analyzer/ippl: Port to EAPI 7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch44
-rw-r--r--net-analyzer/ippl/ippl-1.4.14-r5.ebuild56
-rw-r--r--net-analyzer/ippl/ippl-1.4.14-r6.ebuild46
3 files changed, 90 insertions, 56 deletions
diff --git a/net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch b/net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch
new file mode 100644
index 000000000000..c6c65cb14d50
--- /dev/null
+++ b/net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch
@@ -0,0 +1,44 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,10 +11,10 @@
+ all: binary docs
+
+ binary: Makefile Source/Makefile
+- @cd Source && make && cd ..
++ @cd Source && $(MAKE) && cd ..
+
+ docs:
+- @cd Docs && make && cd ..
++ @cd Docs && $(MAKE) && cd ..
+
+ install: all
+ $(INSTALL) -d -m 755 $(SBINDIR)
+@@ -29,7 +29,7 @@
+ $(INSTALL) -m 644 Docs/ippl.conf.5 $(MANDIR)/man5/ippl.conf.5
+
+ clean:
+- @cd Source && make clean && cd .. && cd Docs && make clean && cd ..
++ @cd Source && $(MAKE) clean && cd .. && cd Docs && $(MAKE) clean && cd ..
+
+ distclean: clean
+ $(RM) *~ Makefile.common Makefile Source/Makefile Docs/Makefile build-stamp install-stamp
+--- a/Source/Makefile.in
++++ b/Source/Makefile.in
+@@ -10,7 +10,7 @@
+ CC=@CC@
+ CFLAGS=@CFLAGS@
+ WARNINGS=-Wall@PEDANTIC@
+-LDFLAGS=
++LDFLAGS=@LDFLAGS@
+
+ SRCS= main.c \
+ configuration.c \
+@@ -49,7 +49,7 @@
+ y.tab.c: ippl.y Makefile ../Makefile.common
+ $(YACC) -d $<
+
+-lex.yy.c: ippl.l Makefile ../Makefile.common
++lex.yy.c: ippl.l y.tab.c Makefile ../Makefile.common
+ $(LEX) $<
+
+ clean:
diff --git a/net-analyzer/ippl/ippl-1.4.14-r5.ebuild b/net-analyzer/ippl/ippl-1.4.14-r5.ebuild
deleted file mode 100644
index e436f03ac433..000000000000
--- a/net-analyzer/ippl/ippl-1.4.14-r5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils toolchain-funcs user
-
-DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
-HOMEPAGE="http://pltplp.net/ippl/"
-SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-DEPEND="virtual/yacc
- >=sys-devel/flex-2.5.4a-r4"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/ippl-1.4.14-noportresolve.patch \
- "${FILESDIR}"/ippl-1.4.14-manpage.patch \
- "${FILESDIR}"/ippl-1.4.14-privilege-drop.patch \
- "${FILESDIR}"/ippl-1.4.14-includes.patch \
- "${FILESDIR}"/ippl-1.4.14-format-warnings.patch
-
- sed -i Source/Makefile.in \
- -e 's|^LDFLAGS=|&@LDFLAGS@|g' \
- || die
-
- sed -i Makefile.in \
- -e 's|make |$(MAKE) |g' \
- || die
-
- # fix for bug #351287
- sed -i -e '/lex.yy.c/s/ippl.l/& y.tab.c/' Source/Makefile.in \
- || die
-
- tc-export CC
-}
-
-src_install() {
- dosbin Source/ippl
-
- insinto "/etc"
- doins ippl.conf
-
- doman Docs/{ippl.8,ippl.conf.5}
-
- dodoc BUGS CREDITS HISTORY README TODO
-
- newinitd "${FILESDIR}"/ippl.rc ippl
-}
-
-pkg_postinst() {
- enewuser ippl
-}
diff --git a/net-analyzer/ippl/ippl-1.4.14-r6.ebuild b/net-analyzer/ippl/ippl-1.4.14-r6.ebuild
new file mode 100644
index 000000000000..1cddf3d999fa
--- /dev/null
+++ b/net-analyzer/ippl/ippl-1.4.14-r6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A daemon which logs TCP/UDP/ICMP packets"
+HOMEPAGE="http://pltplp.net/ippl/"
+SRC_URI="http://pltplp.net/ippl/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+BDEPEND="
+ virtual/yacc
+ sys-devel/flex"
+RDEPEND="acct-user/ippl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.14-noportresolve.patch
+ "${FILESDIR}"/${PN}-1.4.14-manpage.patch
+ "${FILESDIR}"/${PN}-1.4.14-privilege-drop.patch
+ "${FILESDIR}"/${PN}-1.4.14-includes.patch
+ "${FILESDIR}"/${PN}-1.4.14-format-warnings.patch
+ # bug #351287
+ "${FILESDIR}"/${PN}-1.4.14-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dosbin Source/ippl
+
+ insinto /etc
+ doins ippl.conf
+
+ doman Docs/{ippl.8,ippl.conf.5}
+ dodoc BUGS CREDITS HISTORY README TODO
+
+ newinitd "${FILESDIR}"/ippl.rc ippl
+}